Skip to content
Permalink
Browse files

Merge pull request #1891 from 2knu/create-w2ui

[w2ui] created with version 1.4.3
  • Loading branch information...
Deraen committed Jun 12, 2019
2 parents c744b27 + 6f7a720 commit eb73a6a0c41200f57c84dc05a5a9c45ae6f653d0
Showing with 442 additions and 0 deletions.
  1. +25 −0 w2ui/README.md
  2. +4 −0 w2ui/boot-cljsjs-checksums.edn
  3. +32 −0 w2ui/build.boot
  4. +381 −0 w2ui/resources/cljsjs/w2ui/common/w2ui.ext.js
@@ -0,0 +1,25 @@
# cljsjs/w2ui

[](dependency)
```clojure
[cljsjs/w2ui "1.4.3-0"] ;; latest release
```
[](/dependency)

This jar comes with `deps.cljs` as used by the [Foreign Libs][flibs] feature
of the ClojureScript compiler. After adding the above dependency to your project
you can require and use the packaged library like so:

```clojure
(ns application.core
(:require cljsjs.w2ui))
```

Externs were generated using https://github.com/jmmk/javascript-externs-generator

[flibs]: https://clojurescript.org/reference/packaging-foreign-deps


For default-style use w2ui.css, which is not included in this package to enable using custom styling.
For example you can use: https://unpkg.com/w2ui@1.4.3/w2ui-1.4.3.min.css
@@ -0,0 +1,4 @@
{"cljsjs/w2ui/development/w2ui.inc.js"
"B3425FD6257199365222D16A7B535C82",
"cljsjs/w2ui/production/w2ui.min.inc.js"
"D1A873DD61524D4E59B1C90DF3D837BE"}
@@ -0,0 +1,32 @@
(set-env!
:resource-paths #{"resources"}
:dependencies '[[cljsjs/boot-cljsjs "0.10.3" :scope "test"]
[cljsjs/jquery "3.4.0-0"]])

(require '[cljsjs.boot-cljsjs.packaging :refer :all])

(def +lib-version+ "1.4.3")
(def +version+ (str +lib-version+ "-0"))

(task-options!
pom {:project 'cljsjs/w2ui
:version +version+
:description "JavaScript UI library for data-driven web applications"
:url "http://w2ui.com/web/"
:scm {:url "https://github.com/cljsjs/packages"}
:license {"MIT" "http://opensource.org/licenses/MIT"}})

(deftask package []
(comp
(download
:url (format "https://unpkg.com/w2ui@%s/w2ui-%s.min.js" +lib-version+ +lib-version+)
:target "cljsjs/w2ui/production/w2ui.min.inc.js")
(download
:url (format "https://unpkg.com/w2ui@%s/w2ui-%s.js" +lib-version+ +lib-version+)
:target "cljsjs/w2ui/development/w2ui.inc.js")
(sift :include #{#"^cljsjs"})
(deps-cljs :name "cljsjs.w2ui"
:requires ["cljsjs.jquery"])
(pom)
(jar)
(validate-checksums)))

0 comments on commit eb73a6a

Please sign in to comment.
You can’t perform that action at this time.