Permalink
Browse files

Set source level explicitly to 1.5 to make clojure compile with JDK7.

Signed-off-by: Stuart Sierra <mail@stuartsierra.com>
  • Loading branch information...
1 parent 7783f62 commit 6dd4fcd192933642fdda2fa68df1ffa00dfde342 @tsdh tsdh committed with stuartsierra Dec 23, 2011
Showing with 2 additions and 2 deletions.
  1. +2 −2 build.xml
View
@@ -36,7 +36,7 @@
<target name="compile-java" depends="init"
description="Compile Java sources.">
<javac srcdir="${jsrc}" destdir="${build}" includeJavaRuntime="yes"
- debug="true" target="1.5"/>
+ debug="true" source="1.5" target="1.5"/>
</target>
<target name="compile-clojure"
@@ -79,7 +79,7 @@
<delete dir="${test-classes}"/>
<mkdir dir="${test-classes}"/>
<!-- <javac srcdir="${jtestsrc}" destdir="${test-classes}" includeJavaRuntime="yes" -->
- <!-- debug="true" target="1.5" includeantruntime="no"/> -->
+ <!-- debug="true" source="1.5" target="1.5" includeantruntime="no"/> -->
<java classname="clojure.lang.Compile"
classpath="${test-classes}:${test}:${build}:${cljsrc}"
failonerror="true"

0 comments on commit 6dd4fcd

Please sign in to comment.