Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Clojure 1.5.0 by default

  • Loading branch information...
commit dd7eacc77743dff2cfe88de5c53c3a38f181f023 1 parent 73aeaef
Michael Klishin authored
Showing with 9 additions and 1 deletion.
  1. +8 −0 ChangeLog.md
  2. +1 −1  project.clj
View
8 ChangeLog.md
@@ -96,6 +96,14 @@ Note that native ElasticSearch client currently relies on [ElasticSearch 0.90.0.
client libraries and some operations will only work with that version.
+### Clojure 1.5 By Default
+
+Elastisch now depends on `org.clojure/clojure` version `1.5.0`. It is still compatible with Clojure 1.3+ and if your `project.clj` depends
+on 1.3 or 1.4, it will be used, but 1.5 is the default now.
+
+We encourage all users to upgrade to 1.5, it is a drop-in replacement for the majority of projects out there.
+
+
### Bulk Request Support
Bulk requests are now supported. All the relevant code is in the `clojurewerkz.elastisch.rest.bulk`
View
2  project.clj
@@ -2,7 +2,7 @@
:url "http://clojureelasticsearch.info"
:description "Minimalistic fully featured well documented Clojure ElasticSearch client"
:license {:name "Eclipse Public License"}
- :dependencies [[org.clojure/clojure "1.4.0"]
+ :dependencies [[org.clojure/clojure "1.5.0"]
[cheshire "5.0.2"]
[clj-http "0.6.4" :exclusions [org.clojure/clojure]]
[clojurewerkz/support "0.12.0"]
Please sign in to comment.
Something went wrong with that request. Please try again.