Skip to content
Permalink
Browse files

Fix failing collectd installation on OSP < 15

The groupoing of conditions in when was done poorly leading to dnf install
running on  a RHEL 7 controller for OSP version < 15. This patch fixes that.

Change-Id: I20d6eca07a1258a777dfc0b6bad7d21eee9d0cc3
  • Loading branch information...
smalleni committed Sep 5, 2019
1 parent 94d0d29 commit 52edb0e7806da05fcf646160015d3da3ad76525a
Showing with 1 addition and 1 deletion.
  1. +1 −1 ansible/install/roles/collectd-openstack/tasks/main.yml
@@ -26,7 +26,7 @@
shell: |
dnf install -y {{ rhos_release_rpm }}
rhos-release {{ osp_release }}
when: "('controller' in group_names) or ('compute' in group_names) and ansible_distribution_major_version == '8'"
when: ('controller' in group_names or 'compute' in group_names) and ansible_distribution_major_version == '8'
become: yes

#

0 comments on commit 52edb0e

Please sign in to comment.
You can’t perform that action at this time.