Skip to content
Permalink
Browse files

Don't use loop to supply multiple items to yum/pip

This fixes a warning.

Change-Id: Ib0e6e290a97d5083a9eed5234b7a0694eed58f08
  • Loading branch information...
smalleni committed Oct 17, 2019
1 parent 5155cd8 commit b94c2241fb96d82169370221f8e74f9783686672
Showing with 23 additions and 26 deletions.
  1. +23 −26 ansible/install/roles/browbeat/tasks/main.yml
@@ -9,36 +9,34 @@

- name: Install dependencies for CentOS
yum:
name: "{{ item }}"
name:
- gcc
- gcc-c++
- git
- libffi-devel
- libsemanage-python
- openssl-devel
- policycoreutils-python
- python-devel
state: present
become: true
with_items:
- gcc
- gcc-c++
- git
- libffi-devel
- libsemanage-python
- openssl-devel
- policycoreutils-python
- python-devel
when: ansible_distribution_major_version < '8'

- name: Install dependencies for RHEL8
yum:
name: "{{ item }}"
name:
- gcc
- gcc-c++
- git
- libffi-devel
- python3-libsemanage
- openssl-devel
- python3-policycoreutils
- python3-devel
- python3-pip
- python3-virtualenv
state: present
become: true
with_items:
- gcc
- gcc-c++
- git
- libffi-devel
- python3-libsemanage
- openssl-devel
- python3-policycoreutils
- python3-devel
- python3-pip
- python3-virtualenv
when: ansible_distribution_major_version == '8'

- name: Install pip
@@ -61,11 +59,10 @@

- name: Install virtualenv and setuptools- zuul user
pip:
name: "{{ item }}"
name:
- virtualenv
- setuptools
become: true
with_items:
- virtualenv
- setuptools
when: ansible_user == "zuul" and ansible_distribution_major_version < '8'

- name: Determine if browbeat directory exists already

0 comments on commit b94c224

Please sign in to comment.
You can’t perform that action at this time.