/usr/share/hue/build/env/bin/python not found #21

Closed
minhlab opened this Issue Feb 7, 2013 · 2 comments

2 participants

@minhlab

I tried to install hue on Ubuntu 12.04 (previously installed and uninstalled CHD4) and got into this error:

ubuntu@server1:~$ sudo apt-get install hue
Reading package lists... Done
Building dependency tree

Reading state information... Done
The following extra packages will be installed:
bigtop-jsvc hadoop hadoop-0.20-mapreduce hadoop-client hadoop-hdfs hadoop-mapreduce hadoop-yarn
hbase hive hue-about hue-beeswax hue-filebrowser hue-help hue-jobbrowser hue-jobsub hue-oozie
hue-plugins hue-proxy hue-shell hue-useradmin libcap2 libopts25 ntp
Suggested packages:
ntp-doc
The following NEW packages will be installed:
bigtop-jsvc hadoop hadoop-0.20-mapreduce hadoop-client hadoop-hdfs hadoop-mapreduce hadoop-yarn
hbase hive hue hue-about hue-beeswax hue-filebrowser hue-help hue-jobbrowser hue-jobsub hue-oozie
hue-plugins hue-proxy hue-shell hue-useradmin libcap2 libopts25 ntp
0 upgraded, 24 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/149 MB of archives.
After this operation, 310 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Selecting previously unselected package libcap2.
(Reading database ...
dpkg: warning: files list file for package `hue-common' missing, assuming package has no files currently installed.
(Reading database ... 36031 files and directories currently installed.)
Unpacking libcap2 (from .../libcap2_1%3a2.22-1ubuntu3_amd64.deb) ...
Selecting previously unselected package libopts25.
Unpacking libopts25 (from .../libopts25_1%3a5.12-0.1ubuntu1_amd64.deb) ...
Selecting previously unselected package ntp.
Unpacking ntp (from .../ntp_1%3a4.2.6.p3+dfsg-1ubuntu3.1_amd64.deb) ...
Selecting previously unselected package bigtop-jsvc.
Unpacking bigtop-jsvc (from .../bigtop-jsvc_0.4+391-1.cdh4.1.3.p0.27~precise-cdh4.1.3_amd64.deb) ...
Selecting previously unselected package hadoop.
Unpacking hadoop (from .../hadoop_2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hadoop-hdfs.
Unpacking hadoop-hdfs (from .../hadoop-hdfs_2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hadoop-0.20-mapreduce.
Unpacking hadoop-0.20-mapreduce (from .../hadoop-0.20-mapreduce_0.20.2+1270-1.cdh4.1.3.p0.23~precise-cdh4.1.3_amd64.deb) ...
Selecting previously unselected package hadoop-yarn.
Unpacking hadoop-yarn (from .../hadoop-yarn_2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hadoop-mapreduce.
Unpacking hadoop-mapreduce (from .../hadoop-mapreduce_2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hadoop-client.
Unpacking hadoop-client (from .../hadoop-client_2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hbase.
Unpacking hbase (from .../hbase_0.92.1+165-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hive.
Unpacking hive (from .../hive_0.9.0+158-1.cdh4.1.3.p0.23~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-plugins.
Unpacking hue-plugins (from .../hue-plugins_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-help.
Unpacking hue-help (from .../hue-help_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-filebrowser.
Unpacking hue-filebrowser (from .../hue-filebrowser_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-about.
Unpacking hue-about (from .../hue-about_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-useradmin.
Unpacking hue-useradmin (from .../hue-useradmin_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-jobbrowser.
Unpacking hue-jobbrowser (from .../hue-jobbrowser_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-jobsub.
Unpacking hue-jobsub (from .../hue-jobsub_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-beeswax.
Unpacking hue-beeswax (from .../hue-beeswax_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-proxy.
Unpacking hue-proxy (from .../hue-proxy_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue-shell.
Unpacking hue-shell (from .../hue-shell_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_amd64.deb) ...
Selecting previously unselected package hue-oozie.
Unpacking hue-oozie (from .../hue-oozie_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Selecting previously unselected package hue.
Unpacking hue (from .../hue_2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3_all.deb) ...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Setting up libcap2 (1:2.22-1ubuntu3) ...
Setting up libopts25 (1:5.12-0.1ubuntu1) ...
Setting up ntp (1:4.2.6.p3+dfsg-1ubuntu3.1) ...

  • Starting NTP server ntpd [ OK ] Setting up bigtop-jsvc (0.4+391-1.cdh4.1.3.p0.27~precise-cdh4.1.3) ... Setting up hadoop (2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... update-alternatives: using /etc/hadoop/conf.empty to provide /etc/hadoop/conf (hadoop-conf) in auto mode. Setting up hadoop-hdfs (2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... Setting up hadoop-0.20-mapreduce (0.20.2+1270-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... Setting up hadoop-yarn (2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... Setting up hadoop-mapreduce (2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... Setting up hadoop-client (2.0.0+556-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... Setting up hbase (0.92.1+165-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... update-alternatives: using /etc/hbase/conf.dist to provide /etc/hbase/conf (hbase-conf) in auto mode. Setting up hive (0.9.0+158-1.cdh4.1.3.p0.23~precise-cdh4.1.3) ... update-alternatives: using /etc/hive/conf.dist to provide /etc/hive/conf (hive-conf) in auto mode. Setting up hue-plugins (2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3) ... Setting up hue-help (2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3) ... /var/lib/dpkg/info/hue-help.postinst: line 40: /usr/share/hue/build/env/bin/python: No such file or directory /var/lib/dpkg/info/hue-help.postinst: line 41: /usr/share/hue/build/env/bin/python: No such file or directory dpkg: error processing hue-help (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of hue-filebrowser: hue-filebrowser depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-filebrowser (--configure): dependency problems - leaving unconfigured Setting up hue-about (2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3) ... No apport report written because the error message indicates its a followup error from a previous failure. /var/lib/dpkg/info/hue-about.postinst: line 40: /usr/share/hue/build/env/bin/python: No such file or directory /var/lib/dpkg/info/hue-about.postinst: line 41: /usr/share/hue/build/env/bin/python: No such file or directory dpkg: error processing hue-about (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of hue-useradmin: hue-useradmin depends on hue-filebrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-filebrowser is not configured yet. hue-useradmin depends on hue-about (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-about is not configured yet. hue-useradmin depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-useradmin (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of hue-jobbrowser: hue-jobbrowser depends on hue-filebrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-filebrowser is not configured yet. hue-jobbrowser depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-jobbrowser (--configure): dependency problemsNo apport report written because MaxReports is reached already No apport report written because MaxReports is reached already No apport report written because MaxReports is reached already No apport report written because MaxReports is reached already - leaving unconfigured dpkg: dependency problems prevent configuration of hue-jobsub: hue-jobsub depends on hue-jobbrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobbrowser is not configured yet. hue-jobsub depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-jobsub (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of hue-beeswax: hue-beeswax depends on hue-jobbrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobbrowser is not configured yet. hue-beeswax depends on hue-jobsub (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobsub is not configured yet. hue-beeswax depends on hue-filebrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-filebrowser is not configured yet. hue-beeswax depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-beeswax (--configure): dependency problems - leaving unconfigured Setting up hue-proxy (2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3) ... /var/lib/dpkg/info/hue-proxy.postinst: line 40: /usr/share/hue/build/env/bin/python: No such file or directory /var/lib/dpkg/info/hue-proxy.postinst: line 41: /usr/share/hue/build/env/bin/python: No such file or directory dpkg: error processing hue-proxy (--configure): subprocess installed post-installation script returned error exit status 1 No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of hue-shell: hue-shell depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-shell (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of hue-oozie: hue-oozie depends on hue-jobbrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobbrowser is not configured yet. hue-oozie depends on hue-jobsub (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobsub is not configured yet. hue-oozie depends on hue-filebrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-filebrowser is not configured yet. hue-oozie depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. dpkg: error processing hue-oozie (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already dpkg: dependency problems prevent configuration of hue: hue depends on hue-user; however: Package hue-user is not installed. Package hue-useradmin which provides hue-user is not configured yet. hue depends on hue-about (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-about is not configured yet. hue depends on hue-help (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-help is not configured yet. hue depends on hue-filebrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-filebrowser is not configured yet. hue depends on hue-jobbrowser (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobbrowser is not configured yet. hue depends on hue-jobsub (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-jobsub is not configured yet. hue depends on hue-beeswax (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-beeswax is not configured yet. hue depends on hue-proxy (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-proxy is not configured yet. hue depends on hue-shell (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-shell is not configured yet. hue depends on hue-oozie (= 2.1.0+223-1.cdh4.1.3.p0.20~precise-cdh4.1.3); however: Package hue-oozie is not configured yet. dpkg: error processing hue (--configure): dependency problems - leaving unconfigured No apport report written because MaxReports is reached already Processing triggers for libc-bin ... ldconfig deferred processing now taking place Errors were encountered while processing: hue-help hue-filebrowser hue-about hue-useradmin hue-jobbrowser hue-jobsub hue-beeswax hue-proxy hue-shell hue-oozie hue E: Sub-process /usr/bin/dpkg returned an error code (1)
@romainr romainr was assigned Feb 7, 2013
@minhlab

I figured it out.

I copied /usr/share/hue directory from another machine and tried sudo apt-get purge. I reported something about missing gcc.

I installed gcc and --purge remove everything and install again. Now it's working.

@romainr
Cloudera member

Glad that you found a workaround. This is not normal though and we are going to have a look.

@romainr romainr closed this May 16, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment