Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Can't install hue #31

Closed
prongs opened this Issue Jul 15, 2013 · 3 comments

Comments

Projects
None yet
2 participants

prongs commented Jul 15, 2013

The log is this:

--- Installing core source structure...
--- Installing Desktop core...
INSTALL_DIR=/usr/local/hue make -C desktop install
INSTALL_DIR=/usr/local/hue/desktop/core \
        INSTALL_CONF_DIR=/usr/local/hue/desktop/conf \
        make -C core install-bdist
--- Building egg for Twisted
running bdist_egg
running egg_info
writing requirements to Twisted.egg-info/requires.txt
writing Twisted.egg-info/PKG-INFO
writing top-level names to Twisted.egg-info/top_level.txt
writing dependency_links to Twisted.egg-info/dependency_links.txt
reading manifest file 'Twisted.egg-info/SOURCES.txt'
writing manifest file 'Twisted.egg-info/SOURCES.txt'
installing library code to build/bdist.macosx-10.8-intel/egg
running install_lib
running build_py
running build_ext
clang -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -mno-fused-madd -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c conftest.c -o conftest.o
clang: warning: argument unused during compilation: '-mno-fused-madd'
clang -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -mno-fused-madd -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c conftest.c -o conftest.o
clang: warning: argument unused during compilation: '-mno-fused-madd'
conftest.c:1:10: fatal error: 'sys/epoll.h' file not found
#include <sys/epoll.h>
         ^
1 error generated.
building 'twisted.internet.cfsupport' extension
clang -fno-strict-aliasing -fno-common -dynamic -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -mno-fused-madd -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall -Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch i386 -arch x86_64 -pipe -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c twisted/internet/cfsupport/cfsupport.c -o build/temp.macosx-10.8-intel-2.7/twisted/internet/cfsupport/cfsupport.o -w
twisted/internet/cfsupport/cfsupport.c:128:4: error: assignment to cast is illegal, lvalue casts are not supported
  ((PyObject*)__pyx_v_socket) = Py_None; Py_INCREF(((PyObject*)__pyx_v_socket));
  ~^~~~~~~~~~~~~~~~~~~~~~~~~~ ~
twisted/internet/cfsupport/cfsupport.c:134:4: error: assignment to cast is illegal, lvalue casts are not supported
  ((PyObject *)__pyx_v_socket) = __pyx_1;
  ~^~~~~~~~~~~~~~~~~~~~~~~~~~~ ~
twisted/internet/cfsupport/cfsupport.c:829:4: error: assignment to cast is illegal, lvalue casts are not supported
  ((PyObject*)__pyx_v_obj) = Py_None; Py_INCREF(((PyObject*)__pyx_v_obj));
  ~^~~~~~~~~~~~~~~~~~~~~~~ ~
twisted/internet/cfsupport/cfsupport.c:835:4: error: assignment to cast is illegal, lvalue casts are not supported
  ((PyObject *)__pyx_v_obj) = __pyx_1;
  ~^~~~~~~~~~~~~~~~~~~~~~~~ ~
4 errors generated.
error: command 'clang' failed with exit status 1
make[2]: *** [/Users/rajat.khandelwal/Downloads/hue-2.4.0/desktop/core/build/Twisted/egg.stamp] Error 1
make[1]: *** [.recursive-install-bdist/core] Error 2
make: *** [install-desktop] Error 2
Member

romainr commented Jul 15, 2013

Could you delete
desktop/core/ext-py/Twisted

and retry?

FYI, we are also releasing Hue 2.5 early this week (today very probably)

prongs commented Jul 15, 2013

It passed that phase and now it's building Hue Hadoop Snapshots. A lot of
things being downloaded.

And the "today" is in which timezone?

On Mon, Jul 15, 2013 at 9:58 PM, Romain Rigaux notifications@github.comwrote:

Could you delete
desktop/core/ext-py/Twisted

and retry?

FYI, we are also releasing Hue 2.5 early this week (today very probably)


Reply to this email directly or view it on GitHubhttps://github.com/cloudera/hue/issues/31#issuecomment-20981708
.

Rajat Khandelwal
Undergraduate Student
IIT Delhi

Member

romainr commented Jul 15, 2013

Yes, building pulls a bunch of dependencies. Using the package version is recommended.

The timezone is PST.

@romainr romainr closed this Jul 15, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment