Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"boringtun failed to start" #90

Closed
Daniel15 opened this issue Jul 4, 2019 · 4 comments

Comments

3 participants
@Daniel15
Copy link

commented Jul 4, 2019

This error doesn't give much debugging info, unfortunately:

root@vps12:/home/daniel# boringtun --verbosity debug wg0
boringtun failed to start

root@vps12:/home/daniel# cat /tmp/boringtun.err

root@vps12:/home/daniel# cat /tmp/boringtun.out
Success, daemonized
Timer("Invalid argument")

Debian 9 (Stretch) on an OpenVZ VPS.

@neutronscott

This comment has been minimized.

Copy link

commented Jul 4, 2019

That's the timer thing I mentioned in my issue. See #73 for fix

@neutronscott

This comment has been minimized.

Copy link

commented Jul 4, 2019

I also used a couple command line options to get it going after that:

/root/boringtun -f --disable-multi-queue --disable-drop-priviliges -v debug wgnet0
@vkrasnov

This comment has been minimized.

Copy link
Collaborator

commented Jul 18, 2019

@Daniel15 were you able to solve the problem?

@Daniel15

This comment has been minimized.

Copy link
Author

commented Jul 19, 2019

I haven't tried it again, I ended up using wireguard-go instead. I'll close out this issue as it seems linked the linked PR fixes it.

@Daniel15 Daniel15 closed this Jul 19, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.