Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

63 lines (52 sloc) 1.834 kb
source 'http://rubygems.org'
# Rails itself
gem 'rails', '~> 3.0.5'
# Message bus
gem 'nats', '>= 0.4.10', :require => 'nats/client'
gem 'logging', '>= 1.5.0'
# VCAP common components
gem 'vcap_common', :require => ['vcap/common', 'vcap/component'], :path => '../common'
gem 'vcap_logging', :require => ['vcap/logging']
gem 'vcap_staging', '= 0.1.25'
# For queuing staging tasks
gem 'em-hiredis'
gem 'vcap_stager', '= 0.1.3'
# Databases
gem 'sqlite3'
group :production do
gem 'pg'
# Get blocking postgres working for now, try nonblocking drivers when we have more time
# gem 'postgres-pr', '0.6.3'
# gem 'em_postgresql', '0.3.0'
gem 'mysql2', '>= 0.2.6', :require => nil
# mysql2 includes an EventMachine driver (mysql2/em), don't use em-mysqlplus.
# To enable, set the :database_env :adapter to 'em_mysql2' in config/cloud_controller.yml
#
# Requires a Ruby with Fibers (1.9, rbx, etc), thin (or similar EM-driven appserver), and
# rack-fiber_pool middleware. Additionally there is a patch applied via plugin if this
# adapter is selected.
end
# EventMachine and async support
gem 'eventmachine', '~> 0.12.11.cloudfoundry.2'
gem 'thin', '> 1.2'
gem 'em-http-request', '~> 1.0.0.beta.3', :require => 'em-http'
gem 'em-redis', :require => nil
gem 'rack-fiber_pool', :require => nil
# Support libraries
gem 'yajl-ruby', '>= 0.7.9'
gem 'nokogiri', '>= 1.4.4'
gem 'bcrypt-ruby', '>= 2.1.4'
gem 'ruby-hmac', :require => 'hmac-sha1'
gem 'SystemTimer', :platforms => :mri_18
gem 'uuidtools'
gem 'rest-client', '= 1.6.7'
# rspec-rails is outside the 'test' group in order to consistently provide Rake tasks.
gem 'rspec-rails', '>= 2.4.1'
group :test do
gem 'rspec', '>= 2.4.0', :require => nil
gem 'rcov'
gem 'mocha'
gem 'ci_reporter'
gem 'sinatra' # For service gateway shims
gem 'delorean'
end
Jump to Line
Something went wrong with that request. Please try again.