Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Apply specs errand fails with empty specs #150

Closed
alex-slynko opened this Issue Jan 3, 2018 · 2 comments

Comments

Projects
None yet
4 participants
@alex-slynko
Copy link
Member

alex-slynko commented Jan 3, 2018

When nil is passed, kubectl apply fails.
When empty string is passed, it seems that following line is going to help.
https://github.com/cloudfoundry-incubator/kubo-release/blob/master/jobs/apply-specs/templates/bin/deploy-specs.erb#L19
But actually it renders empty bash function, which is can not be parsed and script fails as well.

@cf-gitbot

This comment has been minimized.

Copy link

cf-gitbot commented Jan 3, 2018

We have created an issue in Pivotal Tracker to manage this:

https://www.pivotaltracker.com/story/show/154030804

The labels on this github issue will be updated when the story is started.

@srm09

This comment has been minimized.

Copy link
Contributor

srm09 commented Jan 4, 2018

Fixed with this commit

@cf-gitbot cf-gitbot added delivered and removed in progress labels Jan 4, 2018

@glestaris glestaris closed this Jan 4, 2018

@cf-gitbot cf-gitbot added accepted and removed delivered labels Jan 4, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.