Skip to content
Browse files

Update ruby package to 1.9.3-p484

  * add new blob for ruby
  * update packaging spec
  • Loading branch information...
1 parent 9675ab0 commit 227ef4368ac47bed20ce1b4d0b22584bbfaae40a Aram Price committed Nov 26, 2013
Showing with 9 additions and 4 deletions.
  1. +1 −1 .ruby-version
  2. +5 −0 config/blobs.yml
  3. +2 −2 packages/ruby/packaging
  4. +1 −1 packages/ruby/spec
View
2 .ruby-version
@@ -1 +1 @@
-1.9.3-p448
+1.9.3-p484
View
5 config/blobs.yml
@@ -542,3 +542,8 @@ buildpack_cache/java-buildpack/http:%2F%2Fdownload.pivotal.io.s3.amazonaws.com%2
sha: !binary |-
OWU0YjQxMWViZmNhMzE1NzFhNzA4ODkyNjA4YzhiNzU0NjhkMGRlNQ==
size: 5674548
+ruby/ruby-1.9.3-p484.tar.gz:
+ object_id: 757e9f79-4d3a-4b0a-80ba-2b9ab1715498
+ sha: !binary |-
+ NmFlODBmNDI0OTY4YjVjZTY2MWVlOWIyYmVlMWMyMWFkYzllZTY3Yw==
+ size: 12576996
View
4 packages/ruby/packaging
@@ -1,7 +1,7 @@
set -e -x
-tar xzf ruby/ruby-1.9.3-p448.tar.gz
-pushd ruby-1.9.3-p448
+tar xzf ruby/ruby-1.9.3-p484.tar.gz
+pushd ruby-1.9.3-p484
./configure --prefix=${BOSH_INSTALL_TARGET} --disable-install-doc --with-opt-dir=/var/vcap/packages/libyaml
make
make install
View
2 packages/ruby/spec
@@ -3,6 +3,6 @@ name: ruby
dependencies:
- libyaml
files:
- - ruby/ruby-1.9.3-p448.tar.gz
+ - ruby/ruby-1.9.3-p484.tar.gz
- ruby/rubygems-1.8.24.tgz
- ruby/bundler-1.2.1.gem

0 comments on commit 227ef43

Please sign in to comment.
Something went wrong with that request. Please try again.