GCF glibc dependencies broken #65

Closed
jberkhahn opened this Issue Jan 23, 2014 · 5 comments

Projects

None yet

4 participants

Member

There was a recent update that switched an lgpl go yaml parsing library for a cgo based one. This has broken using gcf from within a deployed app as it now requires a newer version of glibc (2.14) than is provided on the default bosh-lite environment.

Collaborator

We have created an issue in Pivotal Tracker to manage this. You can view the current status of your issue at: http://www.pivotaltracker.com/story/show/64411220

Contributor

Hi @jberkhahn,

Thanks for pointing this out! We have updated our linux builds to use Ubuntu 10.04, glibc version 2.11.1. Can you check that the new binaries work for you?

Member

I'm still getting the same error when I try to run gcf: /lib/libc.so.6: version `GLIBC_2.14' not found (required by gcf)

This is with the 64-bit linux binary pulled from http://go-cli.s3.amazonaws.com/gcf-linux-amd64.tgz, running on bosh lite.

Contributor
tedsuo commented Jan 28, 2014

@jberkhahn, the gcf binaries are old. We've recently renamed gcf to cf. You should download this: http://go-cli.s3.amazonaws.com/cf-linux-amd64.tgz. Let us know if that one works. Thanks!

Member

@tedsuo Ah, didn't see that you guys had moved it to be the mainline version. It works great now.
Thanks!

@jberkhahn jberkhahn closed this Jan 28, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment