Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 36 lines (34 sloc) 1.496 kb
44823cad » felixhoo
2011-11-22 Make base into a gem
1 $LOAD_PATH.unshift(File.join(File.dirname(__FILE__), "lib"))
2 require "base/version"
3
4 Gem::Specification.new do |s|
5 s.name = "vcap_services_base"
6 s.version = VCAP::Services::Base::VERSION
7 s.platform = Gem::Platform::RUBY
8 s.summary = "VCAP services base module"
83efd10e » felixhoo
2012-07-19 Bump base gem to 1.0.12
9 s.description = "Base class/module to develop CloudFoundry service"
10 s.homepage = "https://github.com/cloudfoundry/vcap-services-base"
b36a949e » andl
2012-06-18 add manifest file to snapshot file
11 s.files = Dir.glob("lib/**/*")
44823cad » felixhoo
2011-11-22 Make base into a gem
12 s.require_path = [ "lib" ]
13 s.author = "CloudFoundry Services Team"
83efd10e » felixhoo
2012-07-19 Bump base gem to 1.0.12
14 s.email = "cf-services@rbcon.com"
44823cad » felixhoo
2011-11-22 Make base into a gem
15
93b1be2b » felixhoo
2012-02-24 bump nats, vcap_common, vcap_services_base gem
16 s.add_dependency "nats", "~> 0.4.22.beta.8"
44823cad » felixhoo
2011-11-22 Make base into a gem
17 s.add_dependency "datamapper", "~> 1.1.0"
18 s.add_dependency "do_sqlite3", "~> 0.10.3"
19 s.add_dependency "eventmachine", "~> 0.12.11.cloudfoundry.3"
20 s.add_dependency "eventmachine_httpserver", "~> 0.2.1"
21 s.add_dependency "json", "~> 1.4.6"
22 s.add_dependency "uuidtools", "~> 2.1.2"
23 s.add_dependency "ruby-hmac", "~> 0.4.0"
83efd10e » felixhoo
2012-07-19 Bump base gem to 1.0.12
24 s.add_dependency "em-http-request", "~> 1.0.0.beta.3"
44823cad » felixhoo
2011-11-22 Make base into a gem
25 s.add_dependency "sinatra", "~> 1.2.3"
fec3a150 » felixhoo
2012-01-05 Merge branch 'master' into services-r7
26 s.add_dependency "thin", "~> 1.3.1"
93b1be2b » felixhoo
2012-02-24 bump nats, vcap_common, vcap_services_base gem
27 s.add_dependency "vcap_common", ">= 1.0.8"
89959192 » Chunjie
2012-05-22 bump vcap_logging gem to 1.0.2 for both services-base and all services.
28 s.add_dependency "vcap_logging", ">=1.0.2"
64faf5e3 » andl
2012-03-14 add snapshot quota and delete snapshot job
29 s.add_dependency "resque", "~> 1.20"
30 s.add_dependency "resque-status", "~> 0.3.2"
31105b71 » andl
2011-12-06 move lifecycle framework into base
31 s.add_dependency "curb", "~> 0.7.16"
b36a949e » andl
2012-06-18 add manifest file to snapshot file
32 s.add_dependency "rubyzip", "~> 0.9.8"
68e85d31 » tangr1
2012-10-03 Use warden API to create iptables rules
33 s.add_dependency "warden-client", "~> 0.0.7"
34 s.add_dependency "warden-protocol", "~> 0.0.9"
0173709e » Harshawardhan Gadgil
2012-12-10 CCNG support for service gateways
35 s.add_dependency "cf-uaa-lib"
44823cad » felixhoo
2011-11-22 Make base into a gem
36 end
Something went wrong with that request. Please try again.