Cloudify's Installation Script
Python
Permalink
Failed to load latest commit information.
tests
.gitignore
.travis.yml
README.md
appveyor.yml
circle.yml
dev-requirements.txt
get-cloudify-composer.py
get-cloudify.py
tox.ini

README.md

Circle CI Build status

This scripts installs Cloudify's CLI (http://github.com/cloudify-cosmo/cloudify-cli).

It currently supports Windows (32 and 64 bit), OSX, Debian/RHEL based distributions and Arch. It requires Python 2.7.x to run. Other than that, it will attempt to install all other requirements for you.

Download manually or:

curl -O http://gigaspaces-repository-eu.s3.amazonaws.com/org/cloudify3/get-cloudify.py
# or
wget http://gigaspaces-repository-eu.s3.amazonaws.com/org/cloudify3/get-cloudify.py

and run:

python get-cloudify.py -h

By default, the script will not install any prerequisites (such as pip, virtualenv, python-dev/devel, etc..) unless explicitly specified. It's important to read the help to understand what the script can do.