Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wont start X Server #4

Closed
nickm324 opened this issue Oct 17, 2018 · 6 comments

Comments

Projects
None yet
2 participants
@nickm324
Copy link

commented Oct 17, 2018

I wrote the 1.0.1 image to SD card booted it with my LCD drivers installed and the display works but it ends up with and error that says xint: unable to connect to X server: connection refused.

Fresh image no changes other than add LCD drivers.

@AustinSaintAubin

This comment has been minimized.

Copy link
Collaborator

commented Oct 17, 2018

Was the web kiosk working before LCD driver install?
You might re flash the SD card and test over HDMI before LCD driver install.

If you are using LCD-show drivers you might look at this post; Rotating Touch [Raspbian 4.14, 3.5 LCD, RP 2]

@nickm324

This comment has been minimized.

Copy link
Author

commented Oct 17, 2018

No, I wrote the image, booted it (display not working) used ssh to access the Pi, installed my LCD drivers, rebooted, Display now works, it continues to boot and ends with the start X error.

@nickm324

This comment has been minimized.

Copy link
Author

commented Oct 17, 2018

If I try and start X manually from the terminal here is what is displayed on the LCD
Display

@AustinSaintAubin

This comment has been minimized.

Copy link
Collaborator

commented Oct 21, 2018

Its very odd that your display did not work BEFORE you installed the LCD drivers.
You might try a fresh install and work to resolve the display issue BEFORE installing LCD drivers.

I will do some testing of my own and see if i can recreate the issues.

@nickm324

This comment has been minimized.

Copy link
Author

commented Oct 21, 2018

I figured it out, all I had to do was create 98-lcd-show.conf because it did not exist and add the below configuration in it. That is not included in the 1.01 release.
Also had to modify the 99-calibration.conf.

cat > /etc/X11/xorg.conf.d/98-lcd-show.conf <<"EOF"
Section "Device"
# WaveShare SpotPear 3.5", framebuffer 1
Identifier "uga"
driver "fbdev"
Option "fbdev" "/dev/fb1"
Option "ShadowFB" "off"
#Option "Rotate" "UD" # Flip Upside Down
Option "SwapbuffersWait" "true"
EndSection

Section "Monitor"
# Primary monitor. WaveShare SpotPear 480x320
Identifier "WSSP"
EndSection

Section "Screen"
Identifier "primary"
Device "uga"
Monitor "WSSP"
EndSection

Section "ServerLayout"
Identifier "default"
Screen 0 "primary" 0 0
EndSection
EOF

@AustinSaintAubin

This comment has been minimized.

Copy link
Collaborator

commented Oct 21, 2018

Glad you where able to figure it out. I had wondered if it was the same issue I had with LCD-Show.
Rotating Touch [Raspbian 4.14, 3.5 LCD, RP 2]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.