Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Oct 26, 2011
  1. OauthToken expects a column named expires_at but the column was valid…

    authored
    …_to. This was changed in 0b2601c but the migrations were never updated. Changed the field for mongoid too.
Commits on Oct 24, 2011
  1. @pelle
  2. @pelle
Commits on Oct 20, 2011
  1. @pelle

    fixed date in gemspec

    pelle authored
  2. @pelle
  3. @pelle

    updated to support latest version of OAuth2 spec. ACTION REQUIRED by …

    pelle authored
    …you if you use provider. See README
  4. @pelle

    Merge pull request #86 from KentonWhite/master

    pelle authored
    OAuthFilter:oauth2_token to rejects headers that explicitly state oauth_version="1.0"
  5. @pelle

    Merge pull request #90 from HeiaHeia/master

    pelle authored
    Allow callback_url equal nil
  6. @pelle
  7. @pelle

    Merge pull request #85 from morgz/0e33e1f5444cad2fa30c156c50bc73bc5a5…

    pelle authored
    …97fbc
    
    Fixed form display (in rails 3.1 at least)
Commits on Oct 5, 2011
  1. @shaliko

    Allow callback_url equal nil

    shaliko authored
  2. @shaliko

    Fixed conflicts

    shaliko authored
Commits on Sep 23, 2011
  1. @KentonWhite

    OAuthFilter:oauth2_token to rejects headers that explicitly state oau…

    KentonWhite authored
    …th_version="1.0"
    
    OAuth 1 allows whitespace between the header parameters, but this is optional.  OAuthFilter was using this optionsl behavior to discriminate between oauth1 and oauth2 tokens.  While most OAuth clients put whitespace between their parameters, some clients do not.  The filter was mis-identifying these tokens as OAuth2 tokens, breaking the authentication chain.
    
    oauth2_token now checks if oauth_version="1.0".  If this is present, then the token is rejected.  oauth_version is an optional paramter.  When it is missing, oauth2_token then defaults to checking for whitespace between the parameters.
Commits on Sep 22, 2011
  1. @morgz

    Form tags need needs <%=

    morgz authored
    Forms weren''t displaying in Rails 3.1
Commits on Aug 4, 2011
  1. @pelle
  2. @pelle

    Merge pull request #77 from hoblin/FIX_current_client_application_method

    pelle authored
    FIX current_client_application method
  3. @rymai @pelle

    Oauth2Token.find was looking for an ID, so use Oauth2Token.first instead

    rymai authored pelle committed
    Also use color in the RSpec output
  4. @rymai @pelle

    Search for Oauth2Token that are authorized and not invalidated in the…

    rymai authored pelle committed
    … Rack middleware
    
    I was surprised that when using `OAuth::Controllers::ApplicationControllerMethods.oauthenticate`, every token were valid for authentication, even the invalidated ones!
    
    So I think this patch fix this (I've updated the specs). I've also simplified a condition in `OAuth::Rack::OAuthFilter#oauth2_token` and the Guardfile to remove the deprecation notice.
  5. @pelle

    should have run the specs

    pelle authored
  6. @pelle

    Merge pull request #80 from marnen/8727dae

    pelle authored
    If options is nil, pass an empty hash instead so OAuth::Consumer won't choke.
  7. @pelle

    Merge pull request #81 from marnen/facebook-sample

    pelle authored
    Better Facebook sample.
  8. @pelle
Commits on Jul 23, 2011
  1. @marnen

    Better Facebook sample.

    marnen authored
Commits on Jul 22, 2011
  1. @marnen
  2. @marnen
Commits on Jul 13, 2011
  1. @hoblin
Commits on Jun 28, 2011
  1. @pelle
  2. @pelle
  3. @pelle

    Merge pull request #68 from akonan/master

    pelle authored
    Generator code needs cleaning up
Commits on Jun 15, 2011
  1. @pelle
  2. @pelle
Commits on May 28, 2011
  1. @akonan

    cleans generators code

    akonan authored
  2. @pelle

    Merge pull request #66 from akonan/master

    pelle authored
    Code in readme cleaned up a bit
  3. @akonan
Commits on May 25, 2011
  1. @pelle

    exposing client to http is now disabled by default

    pelle authored
    twitter client now defaults to use the twitter gem but can be configured to use straight oauth_gem
Something went wrong with that request. Please try again.