COBINHOOD API Documentation
Switch branches/tags
Nothing to show
Clone or download
Latest commit a3cdfb1 Aug 21, 2018

README.md

Prerequisites

You're going to need:

  • Linux or OS X — Windows may work, but is unsupported.
  • Ruby, version 2.3.1 or newer
  • Bundler — If Ruby is already installed, but the bundle command doesn't work, just run gem install bundler in a terminal.

Getting Set Up

Document markdown source: ./source/index.html.md

bundle install
bundle exec middleman server

You can now see the docs at http://localhost:4567. Whoa! That was fast!

Deployment

./deploy.sh
git push origin gh-pages:gh-pages

Now that Slate is all set up on your machine, you'll probably want to learn more about editing Slate markdown, or how to publish your docs.

If you'd prefer to use Docker, instructions are available in the wiki.