Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 32 lines (27 sloc) 1.204 kb
12e475a @fsouza license: added license information
fsouza authored
1 # -*- coding: utf-8 -*-
2
3 # Copyright 2012 splinter authors. All rights reserved.
4 # Use of this source code is governed by a BSD-style
5 # license that can be found in the LICENSE file.
da2fb52 @rafaelcaricio Bugfix in project packaging.
rafaelcaricio authored
6 from setuptools import setup, find_packages
cee1e08 @andrewsmedina Fixed Unicode issue with setup.py.
andrewsmedina authored
7 import codecs
07ae6e6 @hltbra updated setup.py to use README.rst as long description and added a missi...
hltbra authored
8
9
cee1e08 @andrewsmedina Fixed Unicode issue with setup.py.
andrewsmedina authored
10 README = codecs.open('README.rst', encoding='utf-8').read()
11
12 setup(
13 name='splinter',
f3ee204 @andrewsmedina setup: bump to 0.7.2
andrewsmedina authored
14 version='0.7.2',
cee1e08 @andrewsmedina Fixed Unicode issue with setup.py.
andrewsmedina authored
15 description='browser abstraction for web acceptance testing',
16 long_description=README,
17 author='CobraTeam',
18 author_email='andrewsmedina@gmail.com',
e31a5d8 @bubenkoff remove python2.5 workarounds due it's support is not possible anyway.
bubenkoff authored
19 classifiers=[
20 'Programming Language :: Python :: 2',
21 'Programming Language :: Python :: 3',
e6661a7 @fgimian Corrected programming language classifiers
fgimian authored
22 ] + [('Programming Language :: Python :: %s' % x) for x in '2.6 2.7 3.3 3.4'.split()],
cee1e08 @andrewsmedina Fixed Unicode issue with setup.py.
andrewsmedina authored
23 packages=find_packages(exclude=['docs', 'tests', 'samples']),
24 include_package_data=True,
297b358 @maparent use a minimum selenium version, easier to adapt to selenium evolution
maparent authored
25 install_requires=['selenium>=2.44.0'],
e2ffe0d @andrewsmedina updated zope.testbrowser to 4.0.4.
andrewsmedina authored
26 extras_require={'zope.testbrowser': ['zope.testbrowser>=4.0.4',
15cab29 @andrewsmedina support extra requires for django client.
andrewsmedina authored
27 'lxml>=2.3.6', 'cssselect'],
5a38db8 Add missing requirement (six)
izabeera authored
28 'django': ['Django>=1.5.8,<1.9', 'lxml>=2.3.6', 'cssselect', 'six'],
270633b @fgimian Implemented Flask test client driver
fgimian authored
29 'flask': ['Flask>=0.10', 'lxml>=2.3.6', 'cssselect']},
cee1e08 @andrewsmedina Fixed Unicode issue with setup.py.
andrewsmedina authored
30 tests_require=['coverage', 'flask'],
31 )
Something went wrong with that request. Please try again.