An opinionated template for creating a Pod.
Switch branches/tags
Clone or download
orta Merge pull request #232 from ayushgoel/patch-1
Add platform specification
Latest commit 9a85ecc Dec 5, 2018
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
Pod podfile & podspec setup Jun 21, 2014
setup https Apr 24, 2018
templates Add platform specification Dec 4, 2018
.gitignore https Apr 24, 2018
.travis.yml https Apr 24, 2018
CODE_OF_CONDUCT.md https Apr 24, 2018
LICENSE Added a proper license. Apr 2, 2014
NAME-osx.podspec https Apr 24, 2018
NAME.podspec https Apr 24, 2018
POD_LICENSE Added a proper license. Apr 2, 2014
POD_README.md https Apr 24, 2018
README.md https Apr 24, 2018
configure fix configure Jun 24, 2014

README.md

pod-template

An opinionated template for creating a Pod with the following features:

  • Git as the source control management system
  • Clean folder structure
  • Project generation
  • MIT license
  • Testing as a standard
  • Turnkey access to Travis CI
  • Also supports Carthage

Getting started

There are two reasons for wanting to work on this template, making your own or improving the one for everyone's. In both cases you will want to work with the ruby classes inside the setup folder, and the example base template that it works on from inside template/ios/.

Best practices

The command pod lib create aims to be ran along with this guide: https://guides.cocoapods.org/making/using-pod-lib-create.html so any changes of flow should be updated there also.

It is open to communal input, but adding new features, or new ideas are probably better off being discussed in an issue first. In general we try to think if an average Xcode user is going to use this feature or not, if it's unlikely is it a very strongly encouraged best practice ( ala testing / CI. ) If it's something useful for saving a few minutes every deploy, or isn't easily documented in the guide it is likely to be denied in order to keep this project as simple as possible.

Requirements:

  • CocoaPods 1.0.0+