Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

the android 9.0 issue #19452

Open
hk520570 opened this Issue Feb 28, 2019 · 11 comments

Comments

Projects
None yet
2 participants
@hk520570
Copy link

hk520570 commented Feb 28, 2019

  • cocos2d-x version:3.10
  • devices test on: android 9.0
  • developing environments
    • NDK version:
    • Xcode version:
    • VS version:
    • browser type and version:

In the case of Android 9.0, this app is built specifically for the old Android version, so it may not work properly. Please check for updates or contact the developer.(此应用专为旧版android 打造,因此可能无法正常运行,请检查更新或与开发者联系)

@minggo

This comment has been minimized.

Copy link
Contributor

minggo commented Mar 1, 2019

Can the app run correctly, is it just a warning?

@hk520570

This comment has been minimized.

Copy link
Author

hk520570 commented Mar 1, 2019

Can the app run correctly, is it just a warning?

just warning~~like this:https://www.jianshu.com/p/9dc825ac1c58

@minggo

This comment has been minimized.

Copy link
Contributor

minggo commented Mar 1, 2019

So it seems can not solve it in by engine. The Application should set target SDK version to 17+?

@hk520570

This comment has been minimized.

Copy link
Author

hk520570 commented Mar 1, 2019

So it seems can not solve it in by engine. The Application should set target SDK version to 17+?

how to modify it,I use ->call cocos compile -p android --ap android-28 -m release --compile-script 0
however it has warring!

set targetsdkversion into AndroidManifest.xml
like this:uses-sdk android:minSdkVersion="9" android:targetSdkVersion="17"/ ?
but it cann't work,the failed is: dlopen failed: cocos2djs.so

@minggo

This comment has been minimized.

Copy link
Contributor

minggo commented Mar 1, 2019

I think you should modify target=android-13 in project.properties.

@hk520570

This comment has been minimized.

Copy link
Author

hk520570 commented Mar 1, 2019

thank you! I try it

@hk520570

This comment has been minimized.

Copy link
Author

hk520570 commented Mar 1, 2019

my project.properties set:target=android-28,but it has warring

@minggo

This comment has been minimized.

Copy link
Contributor

minggo commented Mar 4, 2019

it is strange, i will find a device to test

@hk520570

This comment has been minimized.

Copy link
Author

hk520570 commented Mar 4, 2019

it is strange, i will find a device to test

thank you~

@minggo

This comment has been minimized.

Copy link
Contributor

minggo commented Mar 6, 2019

We found 3.10 can not work on Android 9, crashed when start up. But 3.17.1 works.

@hk520570

This comment has been minimized.

Copy link
Author

hk520570 commented Mar 6, 2019

We found 3.10 can not work on Android 9, crashed when start up. But 3.17.1 works.

my new workspace use 3.16,but 3.10 work well on Android 9,but it has warring

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.