Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Move development dependencies from Gemfile to .gemspec. See http://ye…

  • Loading branch information...
commit cf7d6fa378d9f02e3e38786aea26077c006ca28a 1 parent 088c8f3
@DWvanGeest DWvanGeest authored ryanfitz committed
Showing with 11 additions and 156 deletions.
  1. +1 −0  .gitignore
  2. +1 −25 Gemfile
  3. +0 −131 Gemfile.lock
  4. +9 −0 backbone-rails.gemspec
View
1  .gitignore
@@ -7,3 +7,4 @@ test/dummy/tmp/
test/dummy/.sass-cache/
test/tmp/**/*
.idea/
+Gemfile.lock
View
26 Gemfile
@@ -1,27 +1,3 @@
source "http://rubygems.org"
-gem "rails", "~> 3.2.0"
-# Bundle edge Rails instead:
-# gem 'rails', :git => "git://github.com/rails/rails.git", :branch => "3-1-stable"
-# gem 'tilt', :git => "git://github.com/rtomayko/tilt.git"
-# gem 'sprockets', "~> 2.0.0.beta.13"
-# gem 'execjs', :git => "git://github.com/sstephenson/execjs.git"
-
-gem 'sqlite3'
-gem 'sass'
-gem 'coffee-script'
-gem 'uglifier'
-gem 'jquery-rails'
-gem 'ejs'
-
-if RUBY_VERSION < '1.9'
- gem "ruby-debug", ">= 0.10.3"
-else
- gem "ruby-debug19"
-end
-
-group :test do
- gem "mocha", ">= 0.9.12"
- gem "turn", ">= 0.8.2"
- gem "minitest"
-end
+gemspec
View
131 Gemfile.lock
@@ -1,131 +0,0 @@
-GEM
- remote: http://rubygems.org/
- specs:
- actionmailer (3.2.0)
- actionpack (= 3.2.0)
- mail (~> 2.4.0)
- actionpack (3.2.0)
- activemodel (= 3.2.0)
- activesupport (= 3.2.0)
- builder (~> 3.0.0)
- erubis (~> 2.7.0)
- journey (~> 1.0.0)
- rack (~> 1.4.0)
- rack-cache (~> 1.1)
- rack-test (~> 0.6.1)
- sprockets (~> 2.1.2)
- activemodel (3.2.0)
- activesupport (= 3.2.0)
- builder (~> 3.0.0)
- activerecord (3.2.0)
- activemodel (= 3.2.0)
- activesupport (= 3.2.0)
- arel (~> 3.0.0)
- tzinfo (~> 0.3.29)
- activeresource (3.2.0)
- activemodel (= 3.2.0)
- activesupport (= 3.2.0)
- activesupport (3.2.0)
- i18n (~> 0.6)
- multi_json (~> 1.0)
- ansi (1.4.1)
- archive-tar-minitar (0.5.2)
- arel (3.0.0)
- builder (3.0.0)
- coffee-script (2.2.0)
- coffee-script-source
- execjs
- coffee-script-source (1.2.0)
- columnize (0.3.6)
- ejs (1.1.1)
- erubis (2.7.0)
- execjs (1.3.0)
- multi_json (~> 1.0)
- hike (1.2.1)
- i18n (0.6.0)
- journey (1.0.0)
- jquery-rails (2.0.0)
- railties (>= 3.2.0.beta, < 5.0)
- thor (~> 0.14)
- json (1.6.5)
- linecache19 (0.5.12)
- ruby_core_source (>= 0.1.4)
- mail (2.4.1)
- i18n (>= 0.4.0)
- mime-types (~> 1.16)
- treetop (~> 1.4.8)
- metaclass (0.0.1)
- mime-types (1.17.2)
- minitest (2.10.1)
- mocha (0.10.3)
- metaclass (~> 0.0.1)
- multi_json (1.0.4)
- polyglot (0.3.3)
- rack (1.4.0)
- rack-cache (1.1)
- rack (>= 0.4)
- rack-ssl (1.3.2)
- rack
- rack-test (0.6.1)
- rack (>= 1.0)
- rails (3.2.0)
- actionmailer (= 3.2.0)
- actionpack (= 3.2.0)
- activerecord (= 3.2.0)
- activeresource (= 3.2.0)
- activesupport (= 3.2.0)
- bundler (~> 1.0)
- railties (= 3.2.0)
- railties (3.2.0)
- actionpack (= 3.2.0)
- activesupport (= 3.2.0)
- rack-ssl (~> 1.3.2)
- rake (>= 0.8.7)
- rdoc (~> 3.4)
- thor (~> 0.14.6)
- rake (0.9.2.2)
- rdoc (3.12)
- json (~> 1.4)
- ruby-debug-base19 (0.11.25)
- columnize (>= 0.3.1)
- linecache19 (>= 0.5.11)
- ruby_core_source (>= 0.1.4)
- ruby-debug19 (0.11.6)
- columnize (>= 0.3.1)
- linecache19 (>= 0.5.11)
- ruby-debug-base19 (>= 0.11.19)
- ruby_core_source (0.1.5)
- archive-tar-minitar (>= 0.5.2)
- sass (3.1.12)
- sprockets (2.1.2)
- hike (~> 1.2)
- rack (~> 1.0)
- tilt (~> 1.1, != 1.3.0)
- sqlite3 (1.3.5)
- thor (0.14.6)
- tilt (1.3.3)
- treetop (1.4.10)
- polyglot
- polyglot (>= 0.3.1)
- turn (0.8.3)
- ansi
- tzinfo (0.3.31)
- uglifier (1.2.2)
- execjs (>= 0.3.0)
- multi_json (>= 1.0.2)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- coffee-script
- ejs
- jquery-rails
- minitest
- mocha (>= 0.9.12)
- rails (~> 3.2.0)
- ruby-debug19
- sass
- sqlite3
- turn (>= 0.8.2)
- uglifier
View
9 backbone-rails.gemspec
@@ -14,6 +14,15 @@ Gem::Specification.new do |s|
s.add_dependency('railties', '>= 3.1.0')
s.add_dependency('coffee-script', '~> 2.2.0')
s.add_dependency('ejs', '~> 1.1.1')
+
+ s.add_development_dependency('rails', '~> 3.2.0')
+ s.add_development_dependency('sqlite3')
+ s.add_development_dependency('sass')
+ s.add_development_dependency('uglifier')
+ s.add_development_dependency('jquery-rails')
+ s.add_development_dependency('mocha', '~> 0.10.3')
+ s.add_development_dependency('turn', '~> 0.8.3')
+ s.add_development_dependency('minitest', '~> 2.10.1')
s.require_paths = ['lib']
end
Please sign in to comment.
Something went wrong with that request. Please try again.