Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[AC-10] Confluence 7.0 Final and 7.1 Final Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) #10

Closed
clouless opened this issue Aug 22, 2019 · 3 comments
Labels
Milestone

Comments

@clouless
Copy link
Member

@clouless clouless commented Aug 22, 2019

Story

As described in Preparing for Confluence 7.0 many things change and we need to adapt those changes.

Acceptance Criteria

  • Fix DI-Setter Deprecation with Confluence 7 by using @Inject on Properties or Constructors. Remove Setter-DI.
  • Ensure Data Center CDN Support Confluence 7
  • Fix Guava CharMatcher Deprecations in Confluence 7 and make it downward Confluence 6 compatible
  • Add more e2e tests
  • Retested for Confluence 7.1
@clouless clouless changed the title [AC-X] Confluence 7.0 Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) [AC-10] Confluence 7.0 Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) Aug 22, 2019
@clouless

This comment has been minimized.

Copy link
Member Author

@clouless clouless commented Aug 22, 2019

Internal Issues

  • [ACB-INT-76] Data Center CDN Support Confluence 7
  • [ACB-INT-78] Fix DI-Setter Deprecation with Confluence 7
  • [ACB-INT-77] Guava CharMatcher.INVISIBLE deprecation in Confluence 7
  • [ACB-INT-81] More E2E Tests for core functionality
@clouless clouless added this to the 3.1.0 milestone Aug 22, 2019
@clouless clouless added the story label Aug 22, 2019
@clouless clouless closed this Aug 22, 2019
@clouless clouless changed the title [AC-10] Confluence 7.0 Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) [AC-10] Confluence 7.0 Beta1 Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) Aug 22, 2019
@jahdroid jahdroid changed the title [AC-10] Confluence 7.0 Beta1 Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) [AC-10] Confluence 7.0 Beta1 and 7.0 Final Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) Sep 11, 2019
@jahdroid

This comment has been minimized.

Copy link
Member

@jahdroid jahdroid commented Sep 11, 2019

retested on dockerized Confluence Data Center 7.0.1 Final

docker run  --name="confluence7" -d -p 8090:8090 -p 8091:8091 atlassian/confluence-server:7.0.1-alpine-adoptopenjdk8
@clouless clouless changed the title [AC-10] Confluence 7.0 Beta1 and 7.0 Final Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) [AC-10] Confluence 7.0 Final and 7.1 Final Compatibility (CDN Support, Guava Upgrade, Setter-Dependency-Injection Deprecation) Nov 8, 2019
@clouless

This comment has been minimized.

Copy link
Member Author

@clouless clouless commented Nov 8, 2019

retested on dockerized Confluence Data Center 7.1.0 Final

docker run  --name="confluence7" -d -p 8090:8090 -p 8091:8091 atlassian/confluence-server:7.1.0-adoptopenjdk8
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.