Permalink
Browse files

add versions to gemspec so that using the gem with 1.8.7 doesn't brea…

…k it
  • Loading branch information...
codegoblin committed May 11, 2012
1 parent dc022bd commit 36d9474070e0ae6eb73e7daaa43bf57792b3326a
Showing with 5 additions and 6 deletions.
  1. +5 −6 awesm.gemspec
View
@@ -4,8 +4,8 @@ require "awesm/version"
Gem::Specification.new do |s|
s.name = "awesm"
s.version = Awesm::VERSION
- s.authors = ["Sathya Sekaran", "Michael Durnhofer"]
- s.email = ["sfsekaran@gmail.com", "mdurnhofer@gmail.com"]
+ s.authors = ["Sathya Sekaran", "Michael Durnhofer", "Cody Johnston"]
+ s.email = ["sfsekaran@gmail.com", "mdurnhofer@gmail.com", "cody@codegobl.in"]
s.homepage = "http://github.com/sfsekaran/awesm"
s.summary = %q{Totally awe.sm!}
s.description = %q{The 'awesm' gem is an interface for awe.sm (http://totally.awe.sm), a social link analytics tracking service.}
@@ -19,14 +19,13 @@ Gem::Specification.new do |s|
# specify any dependencies here;
s.add_development_dependency "rake"
- s.add_development_dependency "rspec"
- s.add_development_dependency "webmock"
- s.add_development_dependency "httparty"
+ s.add_development_dependency "rspec", "= 2.7.0"
+ s.add_development_dependency "webmock", "= 1.7.8"
s.add_development_dependency "json"
s.add_development_dependency "hashie"
s.add_development_dependency "ruby-debug"
- s.add_runtime_dependency "httparty"
+ s.add_runtime_dependency "httparty", "= 0.8.1"
s.add_runtime_dependency "json"
s.add_runtime_dependency "hashie"
end

0 comments on commit 36d9474

Please sign in to comment.