Skip to content
Browse files

Try again

  • Loading branch information...
1 parent 50c4854 commit 7193826c474b7ba0d5c143924a915a28b4ee014c @ywen ywen committed Jan 25, 2014
Showing with 333 additions and 3 deletions.
  1. +0 −1 .gitignore
  2. +0 −1 .travis.yml
  3. +1 −0 Gemfile
  4. +332 −0 Gemfile.lock
  5. +0 −1 spinach.gemspec
View
1 .gitignore
@@ -16,5 +16,4 @@ test/tmp
test/version_tmp
tmp
capybara-*.html
-Gemfile.lock
tags
View
1 .travis.yml
@@ -2,7 +2,6 @@ rvm:
- 1.9.3
- 2.0.0
- 2.1.0
- - rbx-19mode
- rbx
cache: bundler
View
1 Gemfile
@@ -23,3 +23,4 @@ end
group :docs do
gem 'yard'
end
+gem 'rubysl', :platforms => :rbx
View
332 Gemfile.lock
@@ -0,0 +1,332 @@
+PATH
+ remote: .
+ specs:
+ spinach (0.8.7)
+ colorize (= 0.5.8)
+ gherkin-ruby (>= 0.3.1)
+ json
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ capybara (2.2.1)
+ mime-types (>= 1.16)
+ nokogiri (>= 1.3.3)
+ rack (>= 1.0.0)
+ rack-test (>= 0.5.4)
+ xpath (~> 2.0)
+ celluloid (0.15.2)
+ timers (~> 1.1.0)
+ coderay (1.1.0)
+ colorize (0.5.8)
+ coveralls (0.7.0)
+ multi_json (~> 1.3)
+ rest-client
+ simplecov (>= 0.7)
+ term-ansicolor
+ thor
+ diff-lcs (1.2.5)
+ docile (1.1.2)
+ fakefs (0.5.0)
+ ffi (1.9.3)
+ ffi2-generators (0.1.1)
+ formatador (0.2.4)
+ gherkin-ruby (0.3.1)
+ racc
+ growl (1.0.3)
+ guard (2.3.0)
+ formatador (>= 0.2.4)
+ listen (~> 2.1)
+ lumberjack (~> 1.0)
+ pry (>= 0.9.12)
+ thor (>= 0.18.1)
+ guard-minitest (2.2.0)
+ guard (~> 2.0)
+ minitest (>= 3.0)
+ guard-spinach (0.0.3)
+ guard (>= 1.1)
+ spinach
+ json (1.8.1)
+ listen (2.4.0)
+ celluloid (>= 0.15.2)
+ rb-fsevent (>= 0.9.3)
+ rb-inotify (>= 0.9)
+ lumberjack (1.0.4)
+ metaclass (0.0.2)
+ method_source (0.8.2)
+ mime-types (2.0)
+ mini_portile (0.5.2)
+ minitest (5.2.1)
+ mocha (1.0.0)
+ metaclass (~> 0.0.1)
+ multi_json (1.8.4)
+ nokogiri (1.6.1)
+ mini_portile (~> 0.5.0)
+ pry (0.9.12.4)
+ coderay (~> 1.0)
+ method_source (~> 0.8)
+ slop (~> 3.4)
+ racc (1.4.11)
+ rack (1.5.2)
+ rack-protection (1.5.2)
+ rack
+ rack-test (0.6.2)
+ rack (>= 1.0)
+ rake (10.1.1)
+ rb-fsevent (0.9.4)
+ rb-inotify (0.9.3)
+ ffi (>= 0.5.0)
+ rest-client (1.6.7)
+ mime-types (>= 1.16)
+ rspec (2.14.1)
+ rspec-core (~> 2.14.0)
+ rspec-expectations (~> 2.14.0)
+ rspec-mocks (~> 2.14.0)
+ rspec-core (2.14.7)
+ rspec-expectations (2.14.4)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-mocks (2.14.4)
+ rubysl (2.0.15)
+ rubysl-abbrev (~> 2.0)
+ rubysl-base64 (~> 2.0)
+ rubysl-benchmark (~> 2.0)
+ rubysl-bigdecimal (~> 2.0)
+ rubysl-cgi (~> 2.0)
+ rubysl-cgi-session (~> 2.0)
+ rubysl-cmath (~> 2.0)
+ rubysl-complex (~> 2.0)
+ rubysl-continuation (~> 2.0)
+ rubysl-coverage (~> 2.0)
+ rubysl-csv (~> 2.0)
+ rubysl-curses (~> 2.0)
+ rubysl-date (~> 2.0)
+ rubysl-delegate (~> 2.0)
+ rubysl-digest (~> 2.0)
+ rubysl-drb (~> 2.0)
+ rubysl-e2mmap (~> 2.0)
+ rubysl-english (~> 2.0)
+ rubysl-enumerator (~> 2.0)
+ rubysl-erb (~> 2.0)
+ rubysl-etc (~> 2.0)
+ rubysl-expect (~> 2.0)
+ rubysl-fcntl (~> 2.0)
+ rubysl-fiber (~> 2.0)
+ rubysl-fileutils (~> 2.0)
+ rubysl-find (~> 2.0)
+ rubysl-forwardable (~> 2.0)
+ rubysl-getoptlong (~> 2.0)
+ rubysl-gserver (~> 2.0)
+ rubysl-io-console (~> 2.0)
+ rubysl-io-nonblock (~> 2.0)
+ rubysl-io-wait (~> 2.0)
+ rubysl-ipaddr (~> 2.0)
+ rubysl-irb (~> 2.0)
+ rubysl-logger (~> 2.0)
+ rubysl-mathn (~> 2.0)
+ rubysl-matrix (~> 2.0)
+ rubysl-mkmf (~> 2.0)
+ rubysl-monitor (~> 2.0)
+ rubysl-mutex_m (~> 2.0)
+ rubysl-net-ftp (~> 2.0)
+ rubysl-net-http (~> 2.0)
+ rubysl-net-imap (~> 2.0)
+ rubysl-net-pop (~> 2.0)
+ rubysl-net-protocol (~> 2.0)
+ rubysl-net-smtp (~> 2.0)
+ rubysl-net-telnet (~> 2.0)
+ rubysl-nkf (~> 2.0)
+ rubysl-observer (~> 2.0)
+ rubysl-open-uri (~> 2.0)
+ rubysl-open3 (~> 2.0)
+ rubysl-openssl (~> 2.0)
+ rubysl-optparse (~> 2.0)
+ rubysl-ostruct (~> 2.0)
+ rubysl-pathname (~> 2.0)
+ rubysl-prettyprint (~> 2.0)
+ rubysl-prime (~> 2.0)
+ rubysl-profile (~> 2.0)
+ rubysl-profiler (~> 2.0)
+ rubysl-pstore (~> 2.0)
+ rubysl-pty (~> 2.0)
+ rubysl-rational (~> 2.0)
+ rubysl-readline (~> 2.0)
+ rubysl-resolv (~> 2.0)
+ rubysl-rexml (~> 2.0)
+ rubysl-rinda (~> 2.0)
+ rubysl-rss (~> 2.0)
+ rubysl-scanf (~> 2.0)
+ rubysl-securerandom (~> 2.0)
+ rubysl-set (~> 2.0)
+ rubysl-shellwords (~> 2.0)
+ rubysl-singleton (~> 2.0)
+ rubysl-socket (~> 2.0)
+ rubysl-stringio (~> 2.0)
+ rubysl-strscan (~> 2.0)
+ rubysl-sync (~> 2.0)
+ rubysl-syslog (~> 2.0)
+ rubysl-tempfile (~> 2.0)
+ rubysl-thread (~> 2.0)
+ rubysl-thwait (~> 2.0)
+ rubysl-time (~> 2.0)
+ rubysl-timeout (~> 2.0)
+ rubysl-tmpdir (~> 2.0)
+ rubysl-tsort (~> 2.0)
+ rubysl-un (~> 2.0)
+ rubysl-uri (~> 2.0)
+ rubysl-weakref (~> 2.0)
+ rubysl-webrick (~> 2.0)
+ rubysl-xmlrpc (~> 2.0)
+ rubysl-yaml (~> 2.0)
+ rubysl-zlib (~> 2.0)
+ rubysl-abbrev (2.0.4)
+ rubysl-base64 (2.0.0)
+ rubysl-benchmark (2.0.1)
+ rubysl-bigdecimal (2.0.2)
+ rubysl-cgi (2.0.1)
+ rubysl-cgi-session (2.0.1)
+ rubysl-cmath (2.0.0)
+ rubysl-complex (2.0.0)
+ rubysl-continuation (2.0.0)
+ rubysl-coverage (2.0.3)
+ rubysl-csv (2.0.2)
+ rubysl-english (~> 2.0)
+ rubysl-curses (2.0.1)
+ rubysl-date (2.0.6)
+ rubysl-delegate (2.0.1)
+ rubysl-digest (2.0.3)
+ rubysl-drb (2.0.1)
+ rubysl-e2mmap (2.0.0)
+ rubysl-english (2.0.0)
+ rubysl-enumerator (2.0.0)
+ rubysl-erb (2.0.1)
+ rubysl-etc (2.0.3)
+ ffi2-generators (~> 0.1)
+ rubysl-expect (2.0.0)
+ rubysl-fcntl (2.0.4)
+ ffi2-generators (~> 0.1)
+ rubysl-fiber (2.0.0)
+ rubysl-fileutils (2.0.3)
+ rubysl-find (2.0.1)
+ rubysl-forwardable (2.0.1)
+ rubysl-getoptlong (2.0.0)
+ rubysl-gserver (2.0.0)
+ rubysl-socket (~> 2.0)
+ rubysl-thread (~> 2.0)
+ rubysl-io-console (2.0.0)
+ rubysl-io-nonblock (2.0.0)
+ rubysl-io-wait (2.0.0)
+ rubysl-ipaddr (2.0.0)
+ rubysl-irb (2.0.4)
+ rubysl-e2mmap (~> 2.0)
+ rubysl-mathn (~> 2.0)
+ rubysl-readline (~> 2.0)
+ rubysl-thread (~> 2.0)
+ rubysl-logger (2.0.0)
+ rubysl-mathn (2.0.0)
+ rubysl-matrix (2.1.0)
+ rubysl-e2mmap (~> 2.0)
+ rubysl-mkmf (2.0.1)
+ rubysl-fileutils (~> 2.0)
+ rubysl-shellwords (~> 2.0)
+ rubysl-monitor (2.0.0)
+ rubysl-mutex_m (2.0.0)
+ rubysl-net-ftp (2.0.1)
+ rubysl-net-http (2.0.4)
+ rubysl-cgi (~> 2.0)
+ rubysl-erb (~> 2.0)
+ rubysl-singleton (~> 2.0)
+ rubysl-net-imap (2.0.1)
+ rubysl-net-pop (2.0.1)
+ rubysl-net-protocol (2.0.1)
+ rubysl-net-smtp (2.0.1)
+ rubysl-net-telnet (2.0.0)
+ rubysl-nkf (2.0.1)
+ rubysl-observer (2.0.0)
+ rubysl-open-uri (2.0.0)
+ rubysl-open3 (2.0.0)
+ rubysl-openssl (2.0.6)
+ rubysl-optparse (2.0.1)
+ rubysl-shellwords (~> 2.0)
+ rubysl-ostruct (2.0.4)
+ rubysl-pathname (2.0.0)
+ rubysl-prettyprint (2.0.2)
+ rubysl-prime (2.0.1)
+ rubysl-profile (2.0.0)
+ rubysl-profiler (2.0.1)
+ rubysl-pstore (2.0.0)
+ rubysl-pty (2.0.2)
+ rubysl-rational (2.0.1)
+ rubysl-readline (2.0.2)
+ rubysl-resolv (2.0.0)
+ rubysl-rexml (2.0.2)
+ rubysl-rinda (2.0.0)
+ rubysl-rss (2.0.0)
+ rubysl-scanf (2.0.0)
+ rubysl-securerandom (2.0.0)
+ rubysl-set (2.0.1)
+ rubysl-shellwords (2.0.0)
+ rubysl-singleton (2.0.0)
+ rubysl-socket (2.0.1)
+ rubysl-stringio (2.0.0)
+ rubysl-strscan (2.0.0)
+ rubysl-sync (2.0.0)
+ rubysl-syslog (2.0.1)
+ ffi2-generators (~> 0.1)
+ rubysl-tempfile (2.0.1)
+ rubysl-thread (2.0.2)
+ rubysl-thwait (2.0.0)
+ rubysl-time (2.0.3)
+ rubysl-timeout (2.0.0)
+ rubysl-tmpdir (2.0.0)
+ rubysl-tsort (2.0.1)
+ rubysl-un (2.0.0)
+ rubysl-fileutils (~> 2.0)
+ rubysl-optparse (~> 2.0)
+ rubysl-uri (2.0.0)
+ rubysl-weakref (2.0.0)
+ rubysl-webrick (2.0.0)
+ rubysl-xmlrpc (2.0.0)
+ rubysl-yaml (2.0.4)
+ rubysl-zlib (2.0.1)
+ simplecov (0.8.2)
+ docile (~> 1.1.0)
+ multi_json
+ simplecov-html (~> 0.8.0)
+ simplecov-html (0.8.0)
+ sinatra (1.4.4)
+ rack (~> 1.4)
+ rack-protection (~> 1.4)
+ tilt (~> 1.3, >= 1.3.4)
+ slop (3.4.7)
+ term-ansicolor (1.2.2)
+ tins (~> 0.8)
+ thor (0.18.1)
+ tilt (1.4.1)
+ timers (1.1.0)
+ tins (0.13.1)
+ xpath (2.0.0)
+ nokogiri (~> 1.3)
+ yard (0.8.7.3)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ capybara
+ coveralls
+ fakefs
+ growl
+ guard
+ guard-minitest
+ guard-spinach
+ minitest
+ mocha
+ pry
+ rake
+ rb-fsevent
+ rspec
+ rubysl
+ simplecov
+ sinatra
+ spinach!
+ yard
View
1 spinach.gemspec
@@ -13,7 +13,6 @@ Gem::Specification.new do |gem|
gem.add_runtime_dependency 'gherkin-ruby', '>= 0.3.1'
gem.add_runtime_dependency 'colorize', '0.5.8'
gem.add_runtime_dependency 'json'
- gem.add_runtime_dependency 'rubysl' if RUBY_ENGINE == 'rbx'
gem.add_development_dependency 'rake'
gem.add_development_dependency 'mocha'
gem.add_development_dependency 'sinatra'

4 comments on commit 7193826

@josepjaume
Codegram member

Hey @ywen thank you very much for fixing this :). Maybe in the future you could work on a separate branch in order to prevent a dirty git message log?

Thanks!

@ywen
ywen commented on 7193826 Feb 26, 2014

sure

@ywen
ywen commented on 7193826 Feb 26, 2014

Or squash them

@josepjaume
Codegram member

Thanks! Good work BTW :)

Please sign in to comment.
Something went wrong with that request. Please try again.