Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Facebook SDK outdated #2641

Closed
jmoranrod opened this Issue Dec 11, 2018 · 9 comments

Comments

Projects
None yet
3 participants
@jmoranrod
Copy link

jmoranrod commented Dec 11, 2018

We have received an email from Facebook indicating that the application uses the following SDKs:

  • Facebook SDK for Android v4.7.0
  • Facebook SDK for iOS v4.12.0

That versions refer to the Graph API version of Facebook v2.7 that has become obsolete recently. Facebook suggest updating to the following versions:

  • Facebook SDK for Android v4.39.0
  • Facebook SDK for iOS v4.39.0

If the SDKs are not updated, there is a risk that the application will not work anymore

@codenameone codenameone self-assigned this Dec 12, 2018

@codenameone codenameone added this to the Version 6.0 milestone Dec 12, 2018

@codenameone

This comment has been minimized.

Copy link
Owner

codenameone commented Dec 12, 2018

We'll push out a build hints in the coming update: android.facebookSdkVersion which you can use as:

android.facebookSdkVersion=4.39.0

I haven't tested it so it might fail on newer versions as Facebook is notorious about breaking compatibility. For iOS we already have a similar build hint ios.facebook.version which is used a bit differently:

ios.facebook.version=~>4.39.0

Again the same caveat applies. If there are errors with setting to a specific newer version we'll deal with those specific errors.

@jmoranrod

This comment has been minimized.

Copy link
Author

jmoranrod commented Dec 12, 2018

When will the update be available to do the tests?

@codenameone

This comment has been minimized.

Copy link
Owner

codenameone commented Dec 13, 2018

We push an update every Friday

@codenameone

This comment has been minimized.

Copy link
Owner

codenameone commented Feb 11, 2019

@jmoranrod Is this working for you?
Can I flip this to be the default?

@jmoranrod

This comment has been minimized.

Copy link
Author

jmoranrod commented Feb 12, 2019

Sorry for not having answered before, the SDK works for me correctly.

@codenameone

This comment has been minimized.

Copy link
Owner

codenameone commented Feb 12, 2019

This will be the default in the next update

@codenameone codenameone reopened this Feb 18, 2019

@codenameone codenameone assigned shannah and unassigned codenameone Feb 18, 2019

@codenameone

This comment has been minimized.

Copy link
Owner

codenameone commented Feb 18, 2019

This seems to be broken on iOS possibly because the pod was migrated. I'll revert this back on iOS for the 6.0 release.

@codenameone codenameone modified the milestones: Version 6.0, Version 7.0 Feb 18, 2019

@jmoranrod

This comment has been minimized.

Copy link
Author

jmoranrod commented Feb 19, 2019

Yesterday I tried to send an iOS compilation and I got this error:

Process return code is 0
Executing: / usr / local / bin / pod install Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod "FBSDKCoreKit":
   In Podfile:
     FBSDKCoreKit (~> 4.39.0)

Specs satisfying the `FBSDKCoreKit (~> 4.39.0)` dependency were found, but they required a higher minimum deployment target.
Process return code is 1
Cocoapods failed even after updating master repo

Fixed by changing the build hint from ios.pods.platform =, 7.0 to ios.pods.platform =, 10.0

Edit: Another workaround until Friday: ios.facebook.version=~>4.12.0 and ios.pods.platform =, 7.0

@codenameone

This comment has been minimized.

Copy link
Owner

codenameone commented Feb 20, 2019

Thanks, this should be fixed for the code freeze

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.