Permalink
Browse files

preparing for 3.5.1; modify gemspec s.t. it depends on 3.5.x, so we d…

…on't need to bump the dependency each time a patch to simple-navigation is released. :)
  • Loading branch information...
1 parent 1558962 commit 9257451f3dd9118da409dea281f6f6167d5d386f @mjtko mjtko committed Nov 19, 2011
Showing with 8 additions and 4 deletions.
  1. +4 −0 CHANGELOG
  2. +4 −4 sinatra-simple-navigation.gemspec
View
@@ -1,3 +1,7 @@
+*3.5.1
+
+* depends on simple-navigation 3.5.x
+
*3.5.0
* depends on simple-navigation 3.5.0
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = %q{sinatra-simple-navigation}
- s.version = "3.5.0"
+ s.version = "3.5.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Andi Schacke", "Mark J. Titorenko"]
@@ -35,12 +35,12 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<simple-navigation>, [">= 3.5.0"])
+ s.add_runtime_dependency(%q<simple-navigation>, ["~> 3.5.1"])
else
- s.add_dependency(%q<simple-navigation>, [">= 3.5.0"])
+ s.add_dependency(%q<simple-navigation>, ["~> 3.5.1"])
end
else
- s.add_dependency(%q<simple-navigation>, [">= 3.5.0"])
+ s.add_dependency(%q<simple-navigation>, ["~> 3.5.1"])
end
end

0 comments on commit 9257451

Please sign in to comment.