Browse files

+ initial commit

  • Loading branch information...
1 parent 4276b1f commit d432481c47cd43a2b29cd43419660ce24753b4b2 @andi andi committed Sep 2, 2010
View
1 VERSION
@@ -0,0 +1 @@
+3.0.0
View
1 lib/sinatra/simple-navigation.rb
@@ -0,0 +1 @@
+require 'sinatra/simple_navigation'
View
13 lib/sinatra/simple_navigation.rb
@@ -0,0 +1,13 @@
+require 'simple-navigation'
+
+module Sinatra
+
+ module SimpleNavigation
+ def self.registered(app)
+ app.helpers ::SimpleNavigation::Helpers
+ end
+ end
+
+ ::SimpleNavigation.register
+ helpers ::SimpleNavigation::Helpers
+end
View
BIN pkg/sinatra-simple-navigation-0.0.1.gem
Binary file not shown.
View
BIN pkg/sinatra-simple-navigation-3.0.0.beta1.gem
Binary file not shown.
View
40 sinatra-simple-navigation.gemspec
@@ -0,0 +1,40 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE
+# Instead, edit Jeweler::Tasks in Rakefile, and run `rake gemspec`
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{sinatra-simple-navigation}
+ s.version = "3.0.0.beta1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Andi Schacke"]
+ s.date = %q{2010-09-02}
+ s.description = %q{A Sinatra extension to enable creating navigations with the simple-navigation gem. Also works for Padrino. See http://github.com/andi/simple-navigation for more information on simple-navigation.}
+ s.email = %q{andreas.schacke@gmail.com}
+ s.files = [
+ "Rakefile",
+ "VERSION",
+ "lib/sinatra/simple-navigation.rb",
+ "lib/sinatra/simple_navigation.rb"
+ ]
+ s.homepage = %q{http://github.com/andi/sinatra-simple-navigation}
+ s.rdoc_options = ["--inline-source", "--charset=UTF-8"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = %q{andi}
+ s.rubygems_version = %q{1.3.6}
+ s.summary = %q{A Sinatra extension to enable creating navigations with the simple-navigation gem. Also works for Padrino.}
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<simple-navigation>, ["= 3.0.0.beta2"])
+ else
+ s.add_dependency(%q<simple-navigation>, ["= 3.0.0.beta2"])
+ end
+ else
+ s.add_dependency(%q<simple-navigation>, ["= 3.0.0.beta2"])
+ end
+end

0 comments on commit d432481

Please sign in to comment.