Permalink
Browse files

extract rails engine from pageflow project

  • Loading branch information...
0 parents commit 2d60bb8ebd13a9b2e6650fb68187600899e9caef @tf tf committed May 5, 2014
Showing 849 changed files with 38,536 additions and 0 deletions.
@@ -0,0 +1,10 @@
+.bundle/
+log/*.log
+pkg/
+spec/dummy/db/*.sqlite3
+spec/dummy/db/*.sqlite3-journal
+spec/dummy/log/*.log
+spec/dummy/log/*/*.log
+spec/dummy/log/*/*/*.log
+spec/dummy/tmp/
+spec/dummy/.sass-cache
@@ -0,0 +1 @@
+vendor/assets/javascripts/**
@@ -0,0 +1,22 @@
+{
+ "browser": true,
+ "undef": true,
+ "immed": true,
+ "trailing": true,
+ "globals": {
+ "jQuery": true,
+ "$": true,
+ "Backbone": true,
+ "Cocktail": true,
+ "_": true,
+ "vjs": true,
+ "Audio5js": true,
+ "I18n": true,
+
+ "pageflow": true,
+ "editor": true,
+
+ "confirm": true,
+ "alert": true
+ }
+}
@@ -0,0 +1,6 @@
+rvm:
+ - 1.9.3
+
+script:
+ - "RAILS_ENV=test bundle exec rake db:schema:load"
+ - "bundle exec rspec --tag ~js"
@@ -0,0 +1,10 @@
+source "https://rubygems.org"
+
+gemspec
+
+# Admin interface engine (Rails 4 compatibility: https://github.com/gregbell/active_admin/pull/2326)
+
+gem 'activeadmin', :git => 'https://github.com/codevise/active_admin.git', :branch => 'rails4'
+gem 'ransack'
+gem 'inherited_resources', '1.4.1'
+gem 'formtastic', '2.3.0.rc2'
@@ -0,0 +1,338 @@
+GIT
+ remote: https://github.com/codevise/active_admin.git
+ revision: 72a9c30cef47b3f38c38039de021aaa3194c188b
+ branch: rails4
+ specs:
+ activeadmin (0.6.0)
+ arbre (>= 1.0.1)
+ bourbon (>= 1.0.0)
+ coffee-rails (>= 3.2.0)
+ devise (>= 3.0.2)
+ formtastic (>= 2.3.0.rc2)
+ inherited_resources (>= 1.4.1)
+ jquery-rails (>= 3.0.0)
+ jquery-ui-rails (>= 4.0.0)
+ kaminari (>= 0.13.0)
+ rails (>= 3.2.0)
+ ransack (>= 1.0.0)
+ sass-rails (>= 3.2.0)
+
+PATH
+ remote: .
+ specs:
+ pageflow (0.0.1)
+ activeadmin
+ ar_after_transaction
+ aws-sdk
+ backbone-rails
+ bourbon (~> 3.1.8)
+ cancan
+ devise (~> 3.0.2)
+ devise-async
+ ejs
+ friendly_id (~> 5.0)
+ i18n-js
+ jbuilder (~> 1.2)
+ jquery-fileupload-rails
+ jquery-layout-rails
+ jquery-rails
+ jquery-ui-rails
+ marionette-rails
+ paperclip (~> 3.5)
+ rails (~> 4.0.2)
+ redis
+ redis-namespace
+ resque
+ resque-logger
+ resque-scheduler
+ resque_mailer
+ state_machine
+ state_machine_job
+ videojs_rails
+ wysihtml5-rails
+ yajl-ruby
+ zencoder
+
+GEM
+ remote: https://rubygems.org/
+ specs:
+ actionmailer (4.0.4)
+ actionpack (= 4.0.4)
+ mail (~> 2.5.4)
+ actionpack (4.0.4)
+ activesupport (= 4.0.4)
+ builder (~> 3.1.0)
+ erubis (~> 2.7.0)
+ rack (~> 1.5.2)
+ rack-test (~> 0.6.2)
+ activemodel (4.0.4)
+ activesupport (= 4.0.4)
+ builder (~> 3.1.0)
+ activerecord (4.0.4)
+ activemodel (= 4.0.4)
+ activerecord-deprecated_finders (~> 1.0.2)
+ activesupport (= 4.0.4)
+ arel (~> 4.0.0)
+ activerecord-deprecated_finders (1.0.3)
+ activesupport (4.0.4)
+ i18n (~> 0.6, >= 0.6.9)
+ minitest (~> 4.2)
+ multi_json (~> 1.3)
+ thread_safe (~> 0.1)
+ tzinfo (~> 0.3.37)
+ addressable (2.3.5)
+ ar_after_transaction (0.4.0)
+ activerecord
+ arbre (1.0.1)
+ activesupport (>= 3.0.0)
+ arel (4.0.2)
+ aws-sdk (1.39.0)
+ json (~> 1.4)
+ nokogiri (>= 1.4.4)
+ backbone-rails (1.1.0)
+ rails (>= 3.0.0)
+ bcrypt (3.1.7)
+ bcrypt-ruby (3.1.5)
+ bcrypt (>= 3.1.3)
+ bourbon (3.1.8)
+ sass (>= 3.2.0)
+ thor
+ builder (3.1.4)
+ cancan (1.6.10)
+ capybara (2.1.0)
+ mime-types (>= 1.16)
+ nokogiri (>= 1.3.3)
+ rack (>= 1.0.0)
+ rack-test (>= 0.5.4)
+ xpath (~> 2.0)
+ capybara-webkit (1.1.1)
+ capybara (>= 2.0.2, < 2.2.0)
+ json
+ climate_control (0.0.3)
+ activesupport (>= 3.0)
+ cocaine (0.5.4)
+ climate_control (>= 0.0.3, < 1.0)
+ coffee-rails (4.0.1)
+ coffee-script (>= 2.2.0)
+ railties (>= 4.0.0, < 5.0)
+ coffee-script (2.2.0)
+ coffee-script-source
+ execjs
+ coffee-script-source (1.7.0)
+ colorize (0.5.8)
+ crack (0.4.1)
+ safe_yaml (~> 0.9.0)
+ database_cleaner (1.2.0)
+ devise (3.0.4)
+ bcrypt-ruby (~> 3.0)
+ orm_adapter (~> 0.1)
+ railties (>= 3.2.6, < 5)
+ warden (~> 1.2.3)
+ devise-async (0.8.0)
+ devise (>= 2.2, < 3.2)
+ diff-lcs (1.2.4)
+ domino (0.5.0)
+ capybara (>= 0.4.0)
+ ejs (1.1.1)
+ erubis (2.7.0)
+ eventmachine (1.0.3)
+ execjs (2.0.2)
+ factory_girl (4.2.0)
+ activesupport (>= 3.0.0)
+ factory_girl_rails (4.2.1)
+ factory_girl (~> 4.2.0)
+ railties (>= 3.0.0)
+ faye-websocket (0.4.7)
+ eventmachine (>= 0.12.0)
+ formtastic (2.3.0.rc2)
+ actionpack (>= 3.0)
+ friendly_id (5.0.3)
+ activerecord (>= 4.0.0)
+ has_scope (0.6.0.rc)
+ actionpack (>= 3.2, < 5)
+ activesupport (>= 3.2, < 5)
+ hike (1.2.3)
+ http_parser.rb (0.5.3)
+ i18n (0.6.9)
+ i18n-js (2.1.2)
+ i18n
+ inherited_resources (1.4.1)
+ has_scope (~> 0.6.0.rc)
+ responders (~> 1.0.0.rc)
+ jbuilder (1.5.3)
+ activesupport (>= 3.0.0)
+ multi_json (>= 1.2.0)
+ jquery-fileupload-rails (0.4.1)
+ actionpack (>= 3.1)
+ railties (>= 3.1)
+ jquery-layout-rails (0.1.0)
+ jquery-rails
+ jquery-rails (3.1.0)
+ railties (>= 3.0, < 5.0)
+ thor (>= 0.14, < 2.0)
+ jquery-ui-rails (4.2.1)
+ railties (>= 3.2.16)
+ json (1.8.1)
+ kaminari (0.15.1)
+ actionpack (>= 3.0.0)
+ activesupport (>= 3.0.0)
+ mail (2.5.4)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ marionette-rails (1.8.3)
+ railties (>= 3.1)
+ mime-types (1.25.1)
+ mini_portile (0.5.2)
+ minitest (4.7.5)
+ mono_logger (1.1.0)
+ multi_json (1.9.2)
+ nokogiri (1.6.1)
+ mini_portile (~> 0.5.0)
+ orm_adapter (0.5.0)
+ paperclip (3.5.4)
+ activemodel (>= 3.0.0)
+ activesupport (>= 3.0.0)
+ cocaine (~> 0.5.3)
+ mime-types
+ phantomjs (1.8.1.1)
+ poltergeist
+ poltergeist (1.3.0)
+ capybara (~> 2.1.0)
+ faye-websocket (>= 0.4.4, < 0.5.0)
+ http_parser.rb (~> 0.5.3)
+ polyamorous (1.0.0)
+ activerecord (>= 3.0)
+ polyglot (0.3.4)
+ rack (1.5.2)
+ rack-protection (1.5.3)
+ rack
+ rack-test (0.6.2)
+ rack (>= 1.0)
+ rails (4.0.4)
+ actionmailer (= 4.0.4)
+ actionpack (= 4.0.4)
+ activerecord (= 4.0.4)
+ activesupport (= 4.0.4)
+ bundler (>= 1.3.0, < 2.0)
+ railties (= 4.0.4)
+ sprockets-rails (~> 2.0.0)
+ railties (4.0.4)
+ actionpack (= 4.0.4)
+ activesupport (= 4.0.4)
+ rake (>= 0.8.7)
+ thor (>= 0.18.1, < 2.0)
+ rake (10.3.1)
+ ransack (1.2.2)
+ actionpack (>= 3.0)
+ activerecord (>= 3.0)
+ activesupport (>= 3.0)
+ i18n
+ polyamorous (~> 1.0.0)
+ redis (3.0.7)
+ redis-namespace (1.4.1)
+ redis (~> 3.0.4)
+ responders (1.0.0)
+ railties (>= 3.2, < 5)
+ resque (1.25.2)
+ mono_logger (~> 1.0)
+ multi_json (~> 1.0)
+ redis-namespace (~> 1.3)
+ sinatra (>= 0.9.2)
+ vegas (~> 0.1.2)
+ resque-logger (0.2.0)
+ resque
+ resque-scheduler (2.5.5)
+ mono_logger (~> 1.0)
+ redis (~> 3.0.4)
+ resque (~> 1.25.1)
+ rufus-scheduler (~> 2.0.24)
+ resque_mailer (2.2.6)
+ actionmailer (>= 3.0)
+ rspec-core (2.14.4)
+ rspec-expectations (2.14.1)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-instafail (0.2.4)
+ rspec-mocks (2.14.3)
+ rspec-rails (2.14.0)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ railties (>= 3.0)
+ rspec-core (~> 2.14.0)
+ rspec-expectations (~> 2.14.0)
+ rspec-mocks (~> 2.14.0)
+ rufus-scheduler (2.0.24)
+ tzinfo (>= 0.3.22)
+ safe_yaml (0.9.5)
+ sass (3.2.19)
+ sass-rails (4.0.3)
+ railties (>= 4.0.0, < 5.0)
+ sass (~> 3.2.0)
+ sprockets (~> 2.8, <= 2.11.0)
+ sprockets-rails (~> 2.0)
+ sinatra (1.4.5)
+ rack (~> 1.4)
+ rack-protection (~> 1.4)
+ tilt (~> 1.3, >= 1.3.4)
+ sprockets (2.11.0)
+ hike (~> 1.2)
+ multi_json (~> 1.0)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
+ sprockets-rails (2.0.1)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ sprockets (~> 2.8)
+ sqlite3 (1.3.9)
+ state_machine (1.2.0)
+ state_machine_job (0.0.5)
+ resque
+ resque-logger
+ state_machine
+ teaspoon (0.7.5)
+ phantomjs (>= 1.8.1.1)
+ railties (>= 3.2.5, < 5)
+ thor (0.19.1)
+ thread_safe (0.3.3)
+ tilt (1.4.1)
+ timecop (0.6.3)
+ treetop (1.4.15)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.39)
+ vegas (0.1.11)
+ rack (>= 1.0.0)
+ videojs_rails (4.5.2)
+ warden (1.2.3)
+ rack (>= 1.0)
+ webmock (1.13.0)
+ addressable (>= 2.2.7)
+ crack (>= 0.3.2)
+ wysihtml5-rails (0.0.4)
+ railties (>= 3.1.0)
+ xpath (2.0.0)
+ nokogiri (~> 1.3)
+ yajl-ruby (1.2.0)
+ zencoder (2.4.6)
+ multi_json
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ activeadmin!
+ capybara
+ capybara-webkit
+ colorize
+ database_cleaner (~> 1.2)
+ domino
+ factory_girl_rails
+ formtastic (= 2.3.0.rc2)
+ inherited_resources (= 1.4.1)
+ pageflow!
+ ransack
+ rspec-instafail
+ rspec-rails (~> 2.0)
+ sqlite3
+ teaspoon
+ timecop
+ webmock
Oops, something went wrong.

0 comments on commit 2d60bb8

Please sign in to comment.