Skip to content
Permalink
Browse files

drop node 6 support

We will no longer test on node6 and instead focus on 8+. This won't
break node6 immediately, but we will no longer go out of our way
supporting a version that does not receive security updates.

Signed-off-by: Claudius <opensource@amenthes.de>
  • Loading branch information...
ccoenen committed May 12, 2019
1 parent 4833f30 commit 806ebe6e1abea47583ec57b6811b67958a2b3369
Showing with 8 additions and 8 deletions.
  1. +1 −1 .babelrc
  2. +4 −4 .travis.yml
  3. +1 −1 docs/setup/manual-setup.md
  4. +2 −2 package.json
@@ -2,7 +2,7 @@
"presets": [
["env", {
"targets": {
"node": "6",
"node": "8",
"uglify": true
}
}]
@@ -4,25 +4,25 @@ cache: yarn
env:
global:
- CXX=g++-4.8
- YARN_VERSION=1.15.2
- YARN_VERSION=1.16.0

jobs:
include:
- env: task=npm-test
node_js:
- 6
- 8
before_install:
- curl -o- -L https://yarnpkg.com/install.sh | bash -s -- --version "$YARN_VERSION"
- export PATH="$HOME/.yarn/bin:$PATH"
- env: task=npm-test
node_js:
- 8
- 10
before_install:
- curl -o- -L https://yarnpkg.com/install.sh | bash -s -- --version "$YARN_VERSION"
- export PATH="$HOME/.yarn/bin:$PATH"
- env: task=npm-test
node_js:
- 10
- 12
before_install:
- curl -o- -L https://yarnpkg.com/install.sh | bash -s -- --version "$YARN_VERSION"
- export PATH="$HOME/.yarn/bin:$PATH"
@@ -3,7 +3,7 @@ Manual Installation

## Requirements on your server

- Node.js 6.x or up (test up to 7.5.0) and <10.x
- Node.js 8.5 or up
- Database (PostgreSQL, MySQL, MariaDB, SQLite, MSSQL) use charset `utf8`
- npm (and its dependencies, [node-gyp](https://github.com/nodejs/node-gyp#installation))
- yarn
@@ -119,7 +119,7 @@
"socket.io": "~2.1.1",
"socket.io-client": "~2.1.1",
"spin.js": "^2.3.2",
"sqlite3": "^4.0.1",
"sqlite3": "^4.0.7",
"store": "^2.0.12",
"string": "^3.3.3",
"tedious": "^1.14.0",
@@ -141,7 +141,7 @@
"**/request": "^2.88.0"
},
"engines": {
"node": ">=6.x"
"node": ">=8.x"
},
"bugs": "https://github.com/codimd/server/issues",
"keywords": [

0 comments on commit 806ebe6

Please sign in to comment.
You can’t perform that action at this time.