Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Is `CMD_URL_PATH` working at the moment? #105

Closed
CHBMB opened this issue Jun 9, 2019 · 2 comments · Fixed by #242
Closed

Is `CMD_URL_PATH` working at the moment? #105

CHBMB opened this issue Jun 9, 2019 · 2 comments · Fixed by #242

Comments

@CHBMB
Copy link
Contributor

@CHBMB CHBMB commented Jun 9, 2019

I'm trying (unsuccessfully) to get CodiMD served up at https://server.com/codimd

I'm wondering a couple of things as I peruse the docs and issues. Firstly am I doing something wrong? I'm starting CodiMD with the following variables.

CMD_DOMAIN=server.com
CMD_PROTOCOL_USESSL=true
CMD_URL_PATH=codimd

Secondly is it possibly broken at the moment?
I normally assume I'm doing something wrong, but I came across this commit from this issue so I just wondered if anyone could clarify?

I have successfully deployed CodiMD using a dedicated subdomain on codimd.server.com without any issues.

Thanks!

@SISheogorath

This comment has been minimized.

Copy link
Member

@SISheogorath SISheogorath commented Jun 9, 2019

Yes, that's correct, this feature is currently broken and someone no one had the time/interest to fix it yet.

Personally I'm considering to just drop it, as I think it's reasonable in 2019 to use an own subdomain for CodiMD especially when you consider the attack vectors that appear when using the same FQDN for multiple services. (i.e. breaking same origin policies, CSPs, …)

I don't recommend those path based setups.

@CHBMB

This comment has been minimized.

Copy link
Contributor Author

@CHBMB CHBMB commented Jun 9, 2019

@SISheogorath Fair enough, as long as I know it's not a PEBKAC error that's fine. 😁

CHBMB added a commit to linuxserver/reverse-proxy-confs that referenced this issue Jun 9, 2019
Subfolder set up currently not working upstream.
codimd/server#105
@CHBMB CHBMB mentioned this issue Jun 9, 2019
bluehood added a commit to bluehood/codimd_server that referenced this issue Dec 17, 2019
It is in fact broken in current master and v1.5.0, see codimd#105.
bluehood added a commit to bluehood/codimd_server that referenced this issue Dec 17, 2019
It is in fact broken in current master and v1.5.0, see codimd#105.
bluehood added a commit to bluehood/codimd_server that referenced this issue Dec 17, 2019
It is in fact broken in current master and v1.5.0, see codimd#105.

Signed-off-by: Enrico Guiraud <enrico.guiraud@cern.ch>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.