Skip to content
Permalink
Browse files

- clarify too old ZScript version message

  • Loading branch information...
madame-rachelle committed Jul 1, 2019
1 parent 259909b commit bc88ceea94886fb82669c542c2836cc93fb42939
Showing with 1 addition and 1 deletion.
  1. +1 −1 src/scripting/zscript/zcc_parser.cpp
@@ -401,7 +401,7 @@ static void DoParse(int lumpnum)
}
if (state.ParseVersion > MakeVersion(VER_MAJOR, VER_MINOR, VER_REVISION))
{
sc.ScriptError("Version mismatch. %d.%d.%d expected but only %d.%d.%d supported", state.ParseVersion.major, state.ParseVersion.minor, state.ParseVersion.revision, VER_MAJOR, VER_MINOR, VER_REVISION);
sc.ScriptError("The file you are attempting to run requires a newer version of " GAMENAME ".\n\nA version with ZScript version %d.%d.%d is required, but your copy of " GAMENAME " only supports %d.%d.%d. Please upgrade!", state.ParseVersion.major, state.ParseVersion.minor, state.ParseVersion.revision, VER_MAJOR, VER_MINOR, VER_REVISION);
}
}
else

0 comments on commit bc88cee

Please sign in to comment.
You can’t perform that action at this time.