Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Keeping pcting's version

  • Loading branch information...
commit 26bde723c26f80acb070d0c5072824bb51057894 1 parent e395229
Colby Gutierrez-Kraybill authored
Showing with 27 additions and 0 deletions.
  1. +27 −0 log4r.gemspec
View
27 log4r.gemspec
@@ -0,0 +1,27 @@
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require 'log4r/version'
+
+# Removed dependency on rake because of error when running `bundle install --deployment`
+# There was a LoadError while evaluating log4r.gemspec:
+# no such file to load -- rake from
+# vendor/bundle/ruby/1.8/bundler/gems/log4r/log4r.gemspec:3
+
+Gem::Specification.new do |gem|
+ # gem is a Gem::Specification... see http://docs.rubygems.org/read/chapter/20 for more options
+ gem.name = "log4r"
+ gem.version = Log4r::VERSION
+ gem.summary = %Q{Log4r, logging framework for ruby}
+ gem.description = %Q{See also: http://logging.apache.org/log4j}
+ gem.email = "colby@astro.berkeley.edu"
+ gem.homepage = "http://log4r.rubyforge.org"
+ gem.authors = ['Colby Gutierrez-Kraybill']
+ gem.bindir = 'bin'
+ gem.test_files = Dir.glob("tests/**/*")
+ gem.files = Dir['doc/**/*'] + Dir['examples/**/*'] + Dir['lib/**/*']
+
+ gem.add_dependency "builder", [">= 2.0.0"]
+ gem.add_development_dependency "bundler", [">= 1.0.0"]
+ gem.add_development_dependency 'rake', ["~> 0.8.7"]
+end
+
Please sign in to comment.
Something went wrong with that request. Please try again.