New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dbi_initialize() is deprecated #950

Closed
octo opened this Issue Feb 26, 2015 · 0 comments

Comments

Projects
None yet
1 participant
@octo
Member

octo commented Feb 26, 2015

It appears that libdbi's interface has changed:

dbi.c: In function 'cdbi_init':
dbi.c:432:3: error: 'dbi_initialize' is deprecated (declared at /usr/include/dbi/dbi.h:169) [-Werror=deprecated-declarations]
   status = dbi_initialize (NULL);
   ^
dbi.c: In function 'cdbi_connect_database':
dbi.c:653:3: error: 'dbi_driver_open' is deprecated (declared at /usr/include/dbi/dbi.h:180) [-Werror=deprecated-declarations]
   driver = dbi_driver_open (db->driver);
   ^
dbi.c:660:5: error: 'dbi_driver_list' is deprecated (declared at /usr/include/dbi/dbi.h:178) [-Werror=deprecated-declarations]
     for (driver = dbi_driver_list (NULL);
     ^
dbi.c:662:9: error: 'dbi_driver_list' is deprecated (declared at /usr/include/dbi/dbi.h:178) [-Werror=deprecated-declarations]
         driver = dbi_driver_list (driver))
         ^

This is package libdbi-dev 0.9.0-1 on Ubuntu 14.04.1.

@octo octo added this to the 5.3 milestone Feb 26, 2015

@octo octo added the Bug label Feb 26, 2015

octo added a commit that referenced this issue Feb 26, 2015

dbi plugin: Switch to libdbi's thread-safe interface.
Macros are in place to make buliding with libdbi <0.9.0 possible.

Fixes: #950

@octo octo closed this Feb 26, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment