Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
148 lines (94 sloc) 4.51 KB

­­Requerimientos de sistema de Plone

Sobre este artículo

Traductor(es):Leonardo J. Caballero G.
Correo(s):leonardoc@plone.org
Compatible con:Plone 3.x, Plone 4.x
Fecha:21 de Marzo de 2015

En esta es una traducción del articulo llamado Plone system requirements.

­Este documento busca definir que tipo de requerimientos de ejecución de una instalación Plone necesita tanto en hardware y sistema operativo.

Requisitos instalar Plone

Para ejecutar un sitio Web basado en Plone usted necesita:

  1. Un computador en modo servidor conectado a Internet (para sitios públicos) o en Intranet (para sitios corporativos).
  2. Acceso a consola de comando para instalar Plone (acceso por FTP, no es suficiente).
  3. Habilidad de ejecutar en procesos como un servicio en el servidor de hospedaje.
  4. Habilidad para abrir puertos arbitrariamente. Zope quiere abrir su propio puerto para recibir solicitudes.

Los proveedores de hospedaje de gama baja no le ofrecen por lo general las opciones número 3 ni número 4. Usted necesita tener proveedor de hospedaje específico para Plone o un servidor dedicado con acceso administrativo exclusivo.

  • Para servidores privados virtuales baratos con acceso root ver http://www.lowendbox.com - Los precios comienzan tan bajo como 7 USD / mes.
  • Si no desea mantener su propio servidor y necesitas una solución de un "solo clic" en nube consulte el servicio Ploud http://www.ploud.com

Requisitos del sistema operativo

  • MS Windows XP o superior.
  • Apple OSX 10.4.x o superior.
  • GNU/Linux 2.6.x o superior.
  • Python 2.6 (opcionalmente Python 2.7, para Plone 4.2 y superior).

Plone requiere tener las herramientas de desarrollo (como el compilador GCC) y otros dependencias para Mac OS X y GNU/Linux instalado previamente para instalar Plone. Estas incluyen las siguientes:

  • libjpeg
  • readline
  • zlib
  • libbz2
  • libxslt
  • libxml2
  • Librería de desarrollo Python

Se recomienda utilizar el administrador de paquetes de su sistema para implementar estas dependencias. Si necesita más instrucciones para instalar estos paquetes favor de referencia: :ref:`Instalación de Plone <instalando_plone>`.

Note

Plone requiere Python 2.6 o 2.7. Las herramientas de Desarrollo son requerida para Linux (GCC).

Requisitos del hardware

Los requerimientos de hardware a continuación dar una estimación aproximada de qué tipo de configuración mínimas de hardware se necesita para un servidor de Plone.

Los productos adicionales y soluciones de caching puede incrementar los requerimientos de memoria RAM.

Un servidor de aplicación Zope esta disponible para ejecutar muchos sitios Plone con la misma configuración de Software. Esto baja los requerimientos cuando hospedas múltiples sitios en el mismo servidor.

Requisitos mínimos de hardware

  • Mínimo 256 MB RAM y 512 MB de memoria de intercambio por cada sitio de Plone.
  • Mínimo 512 MB de espacio de disco duro.

Hardware recomendado

  • 2 GB o más RAM por cada sitio Plone.
  • 40 GB o más de espacio de disco duro.

Note

Plone escala fácilmente. Si está desarrollando un sitio de alto tráfico, su plan de infraestructura para aprovechar sus tecnologías clave, tales como el servidor ZEO y otras estrategias, incluyendo balanceo de carga y almacenamiento en caché.

Soluciones de hospedaje

Por favor, consulte con fines comerciales el sitio plone.org para buscar proveedores de hospedaje o elija cualquier solución de servidor o maquina virtual de hospedaje cumpliendo con los requerimientos de hardware.

Referencias