Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

81 lines (77 sloc) 2.702 kb
# -*- coding:utf-8 -*-
from setuptools import find_packages
from setuptools import setup
version = '1.0b12.dev0'
long_description = (
open('README.rst').read() + '\n' +
open('CONTRIBUTORS.rst').read() + '\n' +
open('CHANGES.rst').read()
)
setup(name='collective.z3cform.widgets',
version=version,
description="A widget package for Dexterity projects.",
long_description=long_description,
classifiers=[
"Development Status :: 4 - Beta",
"Environment :: Web Environment",
"Framework :: Plone",
"Framework :: Plone :: 4.2",
"Framework :: Plone :: 4.3",
"Intended Audience :: Developers",
"License :: OSI Approved :: GNU General Public License v2 (GPLv2)",
"Operating System :: OS Independent",
"Programming Language :: JavaScript",
"Programming Language :: Python",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Topic :: Office/Business :: News/Diary",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Software Development :: User Interfaces",
],
keywords='plone z3cform widgets dexterity',
author='OpenMultimedia',
author_email='contacto@openmultimedia.biz',
url='https://github.com/collective/collective.z3cform.widgets',
license='GPLv2',
packages=find_packages('src'),
package_dir={'': 'src'},
namespace_packages=['collective', 'collective.z3cform'],
include_package_data=True,
zip_safe=False,
install_requires=[
'collective.js.jqueryui',
'plone.app.dexterity',
'plone.app.layout',
'plone.app.vocabularies',
'plone.autoform',
'plone.dexterity',
'plone.directives.form',
'plone.formwidget.autocomplete',
'plone.formwidget.contenttree',
'Products.CMFCore',
'Products.CMFPlone >=4.2',
'Products.GenericSetup',
'setuptools',
'z3c.form',
'zope.browserpage',
'zope.component',
#'zope.i18n', # dont include it, otherwise conflicts in zcml load
'zope.i18nmessageid',
'zope.interface',
'zope.schema',
],
extras_require={
'test': [
'plone.app.robotframework',
'plone.app.testing [robot] >=4.2.2',
'plone.browserlayer',
'plone.testing',
'plone.z3cform',
'robotsuite',
],
},
entry_points="""
[z3c.autoinclude.plugin]
target = plone
""",
)
Jump to Line
Something went wrong with that request. Please try again.