Permalink
Browse files

Suppress strict warnings in PHP 5.4

  • Loading branch information...
1 parent 3cf7553 commit ca34d602fc3d73a1c98d136098d369bb6637a322 @SethKaufman SethKaufman committed Aug 27, 2012
Showing with 2 additions and 2 deletions.
  1. +2 −2 setup.php-dist
View
@@ -200,8 +200,8 @@ require_once(__CA_APP_DIR__.'/version.php');
# includes commonly used classes
require_once(__CA_APP_DIR__.'/helpers/preload.php');
-if (defined('E_DEPRECATED')) { // PHP 5.3
- error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
+if (defined('E_DEPRECATED')) { // PHP 5.3/5.4
+ error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
} else { // PHP <= 5.2
error_reporting(E_ALL & ~E_NOTICE);
}

0 comments on commit ca34d60

Please sign in to comment.