DataMapper backend for delayed_job
Ruby
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
lib Update dependency to dj ~> 4.0 Aug 22, 2014
spec Rename spec_helper to spec/helper Mar 2, 2013
.gitignore Copy .gitignore from main repo Nov 19, 2012
.rspec Copy .rspec from main repo Nov 19, 2012
Gemfile DRY up dependencies and scrap Gemfile.lock Oct 20, 2011
LICENSE.md Add #licenses declaration to gemspec Nov 19, 2012
README.md Cleanup trailing whitespace Nov 19, 2012
Rakefile Use latest rdoc/task Nov 19, 2012
VERSION Update dependency to dj ~> 4.0 Aug 22, 2014
delayed_job_data_mapper.gemspec

README.md

delayed_job DataMapper backend

Installation

Add the gems to your Gemfile:

gem 'delayed_job', '2.1.0.pre2'
gem 'delayed_job_data_mapper', '1.0.0.rc'

If you're using dm-rails gem, add this to your environment.rb:

XXX::Application::configure do
 config.after_initialize do
   Delayed::Worker.backend.auto_upgrade!
 end
end

Otherwise, add an initializer:

Delayed::Worker.backend.auto_upgrade!

That's it. Use delayed_job as normal.