Update to SimpleCov gemspec #70

Merged
merged 1 commit into from Sep 12, 2011

Projects

None yet

3 participants

@sprad
Contributor
sprad commented Sep 10, 2011

Hello Christoph,
I was was receiving the following error when trying to install SimpleCov 0.5.0:

Invalid gemspec in [/Users/jspradlin/.rvm/gems/ruby-1.9.2-p180@jonesy/specifications/simplecov-0.5.0.gemspec]: Illformed requirement ["#Syck::DefaultKey:0x00000109f9e4f8 2.10.3"]

I updated the simplecov.gemspec file to install shoulda as a development dependency using the following syntax:

s.add_development_dependency "shoulda", "~> 2.10.3"

instead of

s.add_development_dependency "shoulda", "2.10.3"

After making this change I was able to install simplecov 0.5.0 without any problems. I ran all of the test and everything still passes.

Thanks,
Justin

My environment is

Ruby 1.9.2-p180
Gem: 1.8.10
Rails 3.1
Mac OSX

@colszowka colszowka merged commit 871fec8 into colszowka:master Sep 12, 2011
@colszowka
Owner

Thanks, my bad!

@sferik
Collaborator
sferik commented Sep 12, 2011

@colszowka Actually, it's not your fault. This issue is covered in some more detail here: http://blog.rubygems.org/2011/08/31/shaving-the-yaml-yacc.html

I'd recommend yanking 0.5.0 and releasing 0.5.1.

@colszowka
Owner

0.5.1 is out, thanks for the fix!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment