Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Announcement of End of Community Support for CometD 5.0.x #1179

Closed
sbordet opened this issue May 10, 2022 · 4 comments
Closed

Announcement of End of Community Support for CometD 5.0.x #1179

sbordet opened this issue May 10, 2022 · 4 comments

Comments

@sbordet
Copy link
Member

sbordet commented May 10, 2022

The CometD project announces the End of Community Support for CometD 5.0.x, following Jetty's announcement of End of Community Support for Jetty 9.x.

September 1st, 2022 will mark the official End of Community Support for CometD 5.0.x.

While users of CometD 5.0.x will continue to see releases for security and critical issues until CometD 5.0.x goes End of Life, the only ongoing support provided will be for Webtide customers.

As for the official End of Life of CometD 5.0.x, we will give at least 6 months notice after the last Webtide customer has transitioned off of using CometD 5.0.x. We can’t provide a firm date, but it is unlikely to happen before 2025.

Thank you for your continued usage and support of CometD.
Please take a moment to look at the newer CometD releases 6.0.x and 7.0.x.

Action Before September 1st, 2022 End of Community Support (September 1st, 2022) End of Life (Date TBD)
Community PRs reviewed and integrated ✔️
Webtide Customer PRs reviewed and integrated ✔️ ✔️
Community triggered releases ✔️
Webtide Customer triggered releases ✔️ ✔️
Security / Vulnerability triggered releases ✔️ ✔️
@inspire99
Copy link

inspire99 commented May 11, 2022

@sbordet , The link regarding eclipse jetty project seems to be incorrect.

Incorrect link --> https://github.com/cometd/cometd/issues/eclipse/jetty.project#7958

Was this the intended link --> jetty/jetty.project#7958 ?

@sbordet
Copy link
Member Author

sbordet commented May 11, 2022

@inspire99 thanks, fixed the link.

@inspire99
Copy link

inspire99 commented May 12, 2022

@sbordet , Regarding cometd 7.0.x, I have seen build jobs for Java 11, Java 17.

https://github.com/cometd/cometd/actions/runs/2108532674

I would like to know whether cometd 7.0.x is backward compatible with Java 8 runtime ?

Thank you.

@sbordet
Copy link
Member Author

sbordet commented May 12, 2022

@inspire99 no, CometD 7.0.x requires Java 11, see https://github.com/cometd/cometd/blob/7.0.x/README.md.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants