New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Better install behavior for packages not in snapshot #272

Closed
snoyberg opened this Issue Jun 11, 2015 · 1 comment

Comments

Projects
None yet
1 participant
@snoyberg
Contributor

snoyberg commented Jun 11, 2015

  • stack install foo should default to whatever's in the snapshot, and if that's not available, choose the latest in the index (reporting as such to the user)
  • To force a specific version of a package to be installed, can run stack install foo-1.2.3
  • For ease of use, can provide stack install foo:latest to ignore whatever's in the snapshot
  • Provide a command stack upgrade which is a synonym for stack install stack:latest

To be especially useful, we should complete #59 as well

@snoyberg snoyberg self-assigned this Jun 11, 2015

@snoyberg snoyberg added this to the First stable release (0.1.0.0?) milestone Jun 11, 2015

@snoyberg

This comment has been minimized.

Contributor

snoyberg commented Jun 11, 2015

I'm going to leave off that last bullet for now, and we can just document the upgrade process elsewhere later.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment