lower pvp-bounds: extraneous version range for a dependency on an internal library #3290
I see this check in cabal - potentially this is from updated software on hackage?
Steps to reproduce
Publish a package to hackage containing an executable with an unbounded dependency on the package's library with a stack.yaml containing
The publish has in the past passed without issues. In hackage I see that the unbounded dependency on the package's library has a lower bound in wolf-0.3.23.cabal, like:
executable wolf-actor build-depends: wolf >=0.3.23,
Now the publish fails with:
I am able to get the publish to pass by manually removing the bounds on the internal library in wolf-0.3.24.cabal, like:
executable wolf-actor main-is: actor.hs build-depends: wolf,
Also tried with 1.5.0:
Method of installation
The text was updated successfully, but these errors were encountered:
Lookin at #3413's "user story": it seems the bug was hard to debug because
That's in addition to fixing this specific
I also can't upload to Hackage with any option for
I have benchmarks in package which depend on library itself.
@mgsloan Thanks for your work! Sorry for long answer...
I tested after
I'm testing on this
$ stack --version Version 1.5.1, Git revision 600c1f01435a10d127938709556c1682ecfd694e (4861 commits) x86_64 hpack-0.17.1
$ stack sdist --pvp-bounds upper $ stack upload --pvp-bounds upper . Getting file list for /home/fenx/programming/haskell/serokell/universum/ Building sdist tarball for /home/fenx/programming/haskell/serokell/universum/ Checking package 'universum' for common mistakes Uploading universum-0.7.1.1.tar.gz... unhandled status code: 400 Error: Invalid package The package has an extraneous version range for a dependency on an internal library: universum <0.8. This version range includes the current package but isn't needed as the current package's library will always be used. Upload failed on universum-0.7.1.1.tar.gz