Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

License is wrong (not FreeBSD?) #14

Closed
huayra opened this Issue · 4 comments

3 participants

@huayra

Why would you make this a GPL project?

I can foresee many issues:
1. Difficult to ship in varnish
2. Even as a VMOD, the modules live in (and link to) varnishd
3. Make it difficult to merge the Varnish FW, VMOD parsereq and this project because of the license
4. You might make live harder for your users. An example of FreeBSD license assumption (see the feature list): http://www.unixy.net/varnish/

You should consider re-licensing it all to FreeBSD, or at least dual-licensing the project.

@comotion
Owner

we'd have to ask gamelinux and Kristian why that is.

@gamelinux
Collaborator

ok for me to move to bsd

@huayra

Kristian was down with it, so I guess we can change the license then. I'll make the change.

@huayra

Sent patch on ticket #16 so closing this ticket as change has been "approved" by all authors.

@huayra huayra closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.