Add correct version of installed dep to component.json #225

Merged
merged 1 commit into from Jan 9, 2013

Conversation

Projects
None yet
2 participants
Contributor

karlbohlmark commented Jan 9, 2013

Currently, component install emitter@0.0.4 adds the dependency "component/emitter@0.0.4": "*" to component.json.

This patch ensures that the dependency added is ""component/emitter"": "0.0.4"

+ name: parts.shift(),
+ version: parts.shift()
+ };
+}
@tj

tj Jan 9, 2013

Contributor

cant remember if we use this elsewhere, might be worth moving it to ./lib

Contributor

tj commented Jan 9, 2013

thanks! nice fix

tj added a commit that referenced this pull request Jan 9, 2013

Merge pull request #225 from karlbohlmark/master
Add correct version of installed dep to component.json

@tj tj merged commit c86f69a into componentjs:master Jan 9, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment