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CHAPTER 1

1 Purpose

Developing solutions for the open source content management system 
OpenCms can become cumbersome. Sooner or later you will ask yourself: 
How do I bridge the gap between the database driven virtual file system and the
real file system so that I can use my IDE of choice?

1.1 Plug-in to the rescue
We at componio are fond lovers of the NetBeans IDE. Thus we decided to 
create a plug-in which enables us to develop for OpenCms in almost the same 
way that we are developing pure web applications. Most notably to create, 
update, import and reverse synchronize OpenCms modules.

In the following chapters you will learn how to configure and build this plug-in 
as well as how to customize the plug-in to fit your build process and specific 
needs.

We primarily offer a binary distribution of the plug-in which is ready to use out
of the box. The latest version of the installable plug-in can be found at 
https://github.com/componio/nbDriva. You may skip directly to chapter 3.
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1.2 A technical glimpse
Since OpenCms stores everything in a database (aka. Virtual File System/VFS) 
and the IDE accesses the file system from the operating system (aka. Real File 
System/RFS) we need to access the data through the OpenCms APIs. 

The often overlooked OpenCms CmsShell is our weapon of choice. It enables 
the plug-in to execute actions originating in NetBeans in the context of the 
OpenCms runtime environment and vice versa. Further the CmsShell bridges 
the gap between the VFS and the RFS enabling the build environment to 
integrate, annotate and package OpenCms resources automatically.

The diagram below outlines the principle modus operandi of the plug-in.
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CHAPTER 2

2 Build the Plug-in

In order to be able to leverage the full potential of the plug-in, we will guide 
you through the build process. Further we will point out enhancements and 
alternative settings where appropriate.

2.1 Requirements
• MySQL[1] Installation

• OpenCms[2],[3] Installation 8.5.x or higher

• NetBeans[4] 7.3.x (with Java EE Base plugin) or higher

• the plug-in sources from github[5][6]

2.2 Plug-in Structure
The plug-in consists of the following components:

• opencms.project.template, template used as the default project structure
and configuration

• net.componio.opencms.projectstructure.plugin, the NetBeans module 
itself

• opencms.shell.extension[6], extended commands based on the CmsShell 
for OpenCms 8.5.x or higher, (e.g. the synchronisation between RFS 
and VFS, synchronization over CMIS interface is also possible)
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Please note that modifications to one component may have side-effects which  
affect the correct functionality of the other components.

2.3 How to build the plugin?
1. Select (File -> Open Project -> 

net.componio.opencms.projectstructure.plugin)

2. Right-click on Project -> Clean and Build

Note: To build the plug-in with Netbeans 7.4 following
workaround has to be proceeded!

3. Right-click on Project -> Libraries -> Select Ant -> Remove

4. Right-click on Project -> Wrapped Jars -> Add Jar -> Select 
<Netbeans 7.4 installation directory>/extide/modules/org-apache-
tools-ant-module.jar

5. Right-click on Project -> Clean and Build Project

2.4 How to install the plugin?
1. Right-click on Project -> Create NBM -> Select Tools -> Plugins -> 

Select Downloaded -> Add Plugins -> Choose <project-
directory>/build/net-componio-opencms-projectstructure-plugin.nbm 
and /build/org-apache-tools-ant-module-library-wrapper.nbm ->Click 
Install

or

2. Right-click on Project -> Install/Reload in Development IDE

NOTE: After execution of “Install/Reload in Development IDE” the
plugin can be just deactivated but not uninstalled.
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2.5 Project Template Modifications
Changes to opencms.project.template require the following steps to be taken:

1. Execute the target zipme in the build.xml of the template which 
generates the zip file OpenCmsProjectStructureTemplateProject.zip in 
return.

2. Replace the zip file in net.componio.opencms.projectstructure.plugin 
with the previously generated zip file.

2.6 Shell Extension Modifications
The opencms.shell.extension[6](available as Maven project on github) utilises the
CmsShell and OpenCms API.  In order to extend the functionality of the plug-
in with your own commands please follow along these steps:

 1 Create a new class, which implements the interface 
I_CmsShellCommands and add your own methods to this class. 
Additionally you can consult the OpenCms classes CmsShell and 
CmsShellCommands from the OpenCms source code for OpenCms 
8[2].

 2 You can build a jar and include it in your project or set up an own 
Maven repository (for the case you want to use the jar in your Maven 
projects)

To build your own Maven repository execute following steps:

 2.1 Install Maven

 2.2 Adapt the pom.xml of opencms.shell.extension and change the path 
of the repository to your desired path.

 2.3 Open a command line and switch to the opencms.shell.extension 
directory

 2.4 Execute mvn deploy

 2.5 Add the Maven repository as dependency to your pom.xml

NOTE: e.g. after you pushed your Maven repository to github you 
need  to modify additionaly the value in opencms.shell.extension-
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[version].pom.sha1(cause the expected and the computed values will 
differ during execution like this:

...-0.1.pom: invalid sha1: 
expected=7f1089041d63ce7eaa5d6a35ddda3aaa606042e3 
computed=8a941ef40645d449b0740023624c2f8b67b84c59 (516ms))

So you have to replace the value in 

opencms.shell.extension-[version].pom.sha1 with the computed one.

Beyond that you can check the ivy.xml and ivy-settings.xml in 
opencms.project.template to see how the repository is added as 
dependency in ivy.

 3 Create a new CmsShell script in the relative scripts folder from which 
you are calling your defined method.

 4 Adapt the build.xml, individual.properties or default.properties and 
buildModuleOperationsWithCmsShell.xml according to your needs.

E.g. in the snippet below the target prepare_createNewModule is used 
to replace a row in the CmsShell script createModule.txt before 
execution.

<target name="prepare_createNewModule">
        <replaceregexp file="$scriptDir}/createNewModule.txt"
                       match="login .*"
                       replace="login &quot;

  ${username}&quot; &quot;
  ${password}&quot;"

                       byline="true"/>

        <replaceregexp file="$scriptDir}/createNewModule.txt"
                       match="createNewModule .*"
                       replace="createNewModule &quot;

  ${modulename}&quot; &quot;
  ${module.version}&quot;"

                       byline="true"/>
</target>

 4.1 In the next screenshot the target run_createNewModule is shown in
which the class CmsShellMain is executed and the CmsShell script 
and the class with the own CmsShell methods are passed to 
CmsShellMain as arguments.

<target name="run_createNewModule"   
depends="prepare_createNewModule">

        <java classname="main.CmsShellMain">
            <arg line="-webInf ${cmsWebInfDir} -script 

 ${scriptDir}/createNewModule.txt
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             -additional additionalcommands.ModuleCommands"/>
            <classpath path="build">
                <dirset dir="${build.classes.dir}">
                    <include name="**/*.class"/>
                </dirset>
                <pathelement path="${java.class.path}"/>
                <pathelement path="${javac.classpath}"/>
            </classpath>

</java>
</target>

6. Execute target zipme in the build.xml of opencms.project.template

7. Replace the zip file in net.componio.opencms.projectstructure.plugin 
with the generated zip file.

8. Add a new action for the context menu with the new functionality in 
net.componio.opencms.projectstructure.plugin (see next section).
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2.7 Context Menu Modifications
To add a new context action (e.g. a new CmsShell command) you can use the 
source code of the plugin as a reference. Additionally, you can check the 
NetBeans Utilities API[7], the wiki page: “How do I create an Action that is 
automatically enabled and disabled depending on the selection?“[8] and the 
article with a similar topic on markiewb's blog[9].
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CHAPTER 3

3 Cumbersome no more!

Now that we have configured and built our plug-in, the time-consuming 
process of build, copy and hit the sync button are over for good.

Install the previously built net-componio-opencms-projectstructure-
plugin.nbm file with your NetBeans IDE (see Tools  → Plugins), restart your 
IDE and you are set to create your first project.
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3.1 Create New Project
1. Select (File -> New Project) in the NetBeans menu bar

2. Choose "OpenCmsProjectStructureTemplate"

3. Click Next -> enter the project name, opencms version and the WEB-
INF path of the opencms installation-> click Finish
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Fig 3.1: Netbeans' New Project Dialogue
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3.2 Initial configuration
1. Include the OpenCms libraries in the libraries section

◦ Option 1: Right-click on Project  select Ivy Resolve →
Dependencies. Apache Ivy[10] will be downloaded, installed and 
the dependencies described in the <project 
directory>/ivy/ivy_opencms_[version].xml (according to the 
selected opencms version) are resolved in conjunction with the 
Maven repository (per default copied into relative lib directory 
of the project). For now these are the required OpenCms and 
MySQL libraries.

Note: The dependencies(version) described in the 
ivy_opencms_[version].xml and the entry “opencms.version” in
<project directory>/default.properties for the OpenCms 
system must match with your target OpenCms installation.

◦ Option 2: Include the required libraries from an OpenCms 
installation manually. Additionally you need Apache Chemistry 
libraries(client side) according to the supported Apache 
Chemistry version by OpenCms.

2. Right-click on Project  Properties  Libraries  Add Jar/Folder  open → → → →
the relative lib/default folder  select all jar files  Open  OK→ → →
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3. Change project-name in build.xml manually

<project name="change_me" ...>

4. Change the values in individual.properties or default.properties 
nbDriva.properties to meet your build environment. The values are 
used in build.xml and buildModuleOperationsWithCmsShell.xml.

Note: Do not change buildModuleOperationsWithCmsShell.xml 
unless you know how the file affects the plugin. Beyond that 
configuration values in default.properties can be overriden with the 
values in individual.properties.

5.

Properties in default.properties/individual.properties

◦ modulename, the name of the OpenCms module to be created

◦ opencms.version=9.5.2, the version of the selected OpenCms 
System.

◦ modulepath=/system/modules, path to the OpenCms-modules
at the OpenCms-system

◦ username=Admin, login data for OpenCms, used in the 
CmsShell-scripts

◦ password=admin, login data for OpenCms, used in the 
CmsShell-scripts

◦ module.version=1.0, version of the module during creation and 
export. (will be incremented by OpenCms during export)

◦ acPackage=${modulepath}/${modulename}, directory of the 
actual module at the OpenCms-System

◦ cmsSync=../../cmsSync, Syncronization folder, used to 
synchronize changes between the Remote File System and the 
Virtual File System(OpenCms-System)

◦ includedSyncFolders= paths(separated with a “,”) of the Virtual
File System, which will be included in the synchronization (can 
be used to avoid that other directories in the cmsSync path will 
be deleted at the sync process)

◦ syncOverCMIS=false, flag to define if the synchronisation is 
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proceeded via CMIS(Apache Chemistry[11])

◦ cmsRepoURL=http://localhost:8080/opencms/cmisatom/, 
URL to the CMIS repository

◦ cmsRepoId=cmis-offline, repository id of a CMIS repository

◦ scriptDir=./scripts, directory to the CmsShell scripts

NOTE: The scripts in this directory are changed dynamically 
via Ant targets so the scripts in this folder shouldn't be changed 
manually)

◦ packagePath=../package, relative package path of the project, 
used to save the exported module (from VFS)

◦ cmsWebInfDir= <somepath>, path to the WEB-INF folder of
the OpenCms installation you want to work with

◦ moduleDir=${cmsWebInfDir}/packages/modules, path to the 
OpenCms modules of the installed OpenCms System.

◦ useExclusionFile=true, flag

◦ importModules=..., import files(separated with a “,”), the 
importModules can be selected over a GUI dialog and 
imported, so this property is changed dynamically over the 
GUI. 

◦ exclusionFile=${basedir}/exclusion/exclusion.patterns.txt, 
Files and directories can be excluded from the sync process via 
exclusion patterns and regular expressions, which are defined in 
the exclusionFile.

◦ ivy.install.version=2.3.0, Apache Ivy version

◦ ivy.jar.dir=${basedir}/ivy, directory for the Apache Ivy 
installation

◦ ivy.jar.file=${ivy.jar.dir}/ivy-${ivy.install.version}.jar

◦ ivy.resolved.libs.dir=${basedir}/lib, destination folder for the 
resolved libraries over Apache Ivy
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3.3 How to use the plug-in?
Right-click on the project to call one of the following actions:
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1. Create Module, the module will be created on the target OpenCms

2. Create Resource Type, creates a resource type over following GUI

3. Import Module, can be used to import OpenCms modules over 
following GUI.
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4. Reverse Sync Module, exports the module from the target 
OpenCms to <project-directory>/package

NOTE: OpenCms increments the version number of a module 
during an export. So you have to define a lower version in your 
individual.properties if you want to have a specific version 
number for your exported module.
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5. Reverse Sync (single files), right-click at a file in the following 
directory structure

NOTE: selected files or directories will be overridden

6. Sync Module, two-way synchronisation between the 
synchronisation folder(RFS) and the VFS of the target OpenCms 
via the CmsShell or a one-way synchronisation with Apache 
Chemistry over CMIS.

7. Module Properties, changes for entries in the individual.properties
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