Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Typo fixes

  • Loading branch information...
commit 6375bc55510726f147f3fdf2951e68267b616b99 1 parent 4bbb168
@shama shama authored
View
2  README.md
@@ -52,7 +52,7 @@ in a system wide way.
1. Change into a directory in your path like `cd /usr/local/bin`
2. Get Composer `curl -s http://getcomposer.org/installer | php`
-3. Make the phar executeable `chmod a+x composer.phar`
+3. Make the phar executable `chmod a+x composer.phar`
4. Change into a project directory `cd /path/to/my/project`
5. Use Composer as you normally would `composer.phar install`
6. Optionally you can rename the composer.phar to composer to make it easier
View
2  doc/00-intro.md
@@ -69,7 +69,7 @@ You can place this file anywhere you wish. If you put it in your `PATH`,
you can access it globally. On unixy systems you can even make it
executable and invoke it without `php`.
-You can run these commands to easily acces `composer` from anywhere on your system:
+You can run these commands to easily access `composer` from anywhere on your system:
$ curl -s http://getcomposer.org/installer | php
$ sudo mv composer.phar /usr/local/bin/composer
View
2  doc/03-cli.md
@@ -254,7 +254,7 @@ If you are using composer from behind an HTTP proxy, you can use the standard
`http_proxy` or `HTTP_PROXY` env vars. Simply set it to the URL of your proxy.
Many operating systems already set this variable for you.
-Using `http_proxy` (lowercased) or even defining both might be preferrable since
+Using `http_proxy` (lowercased) or even defining both might be preferable since
some tools like git or curl will only use the lower-cased `http_proxy` version.
Alternatively you can also define the git proxy using
`git config --global http.proxy <proxy url>`.
View
4 doc/dev/DefaultPolicy.md
@@ -2,10 +2,10 @@
A solver policy defines behaviour variables of the dependency solver. It decides
which versions are considered newer than others, which packages should be
-prefered over others and whether operations like downgrades or uninstall are
+preferred over others and whether operations like downgrades or uninstall are
allowed.
-## Selection of prefered Packages
+## Selection of preferred Packages
The following describe package pool situations with user requests and the
resulting order in which the solver will try to install them.
View
2  doc/faqs/why-can't-composer-load-repositories-recursively.md
@@ -26,7 +26,7 @@ could define the same packages inside a package repository, but with different
dist/source. There are many many ways this could go wrong.
- Fetch the repositories of root package, then fetch the repositories of the
-first level depencies, then fetch the repositories of their dependencies, etc,
+first level dependencies, then fetch the repositories of their dependencies, etc,
then resolve requirements. This sounds more efficient, but it suffers from the
same problems than the second solution, because loading the repositories of the
dependencies is not as easy as it sounds. You need to load all the repos of all
Please sign in to comment.
Something went wrong with that request. Please try again.