Permalink
Browse files

Just output a warning but don't prevent usage through non-cli SAPIs

  • Loading branch information...
Seldaek committed Apr 11, 2013
1 parent 894f530 commit c1ff6ea62bb2c196e777bcd51ac6da287ad44b5a
Showing with 1 addition and 2 deletions.
  1. +1 −2 bin/composer
View
@@ -2,8 +2,7 @@
<?php
if (PHP_SAPI !== 'cli') {
- echo 'Composer should be invoked via the CLI version of PHP, not the '.PHP_SAPI.' SAPI'.PHP_EOL;
- exit(1);
+ echo 'Warning: Composer should be invoked via the CLI version of PHP, not the '.PHP_SAPI.' SAPI'.PHP_EOL;
}
require __DIR__.'/../src/bootstrap.php';

1 comment on commit c1ff6ea

@dhansharma

This comment has been minimized.

Show comment Hide comment
@dhansharma

dhansharma Jan 12, 2015

This maybe of need and service everything . So have me for time people mine belong to bought. I didn't, t his perfect our and the well .

This maybe of need and service everything . So have me for time people mine belong to bought. I didn't, t his perfect our and the well .

Please sign in to comment.