Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Downgrade severity of branch-alias validation failure to warning

  • Loading branch information...
commit ec7088aba502232d6859eb5f2c8854bae40ad72a 1 parent ef0151e
@Seldaek Seldaek authored
Showing with 2 additions and 2 deletions.
  1. +2 −2 src/Composer/Package/Loader/ValidatingArrayLoader.php
View
4 src/Composer/Package/Loader/ValidatingArrayLoader.php
@@ -194,7 +194,7 @@ public function load(array $config, $class = 'Composer\Package\CompletePackage')
foreach ($this->config['extra']['branch-alias'] as $sourceBranch => $targetBranch) {
// ensure it is an alias to a -dev package
if ('-dev' !== substr($targetBranch, -4)) {
- $this->errors[] = 'extra.branch-alias.'.$sourceBranch.' : the target branch ('.$targetBranch.') must end in -dev';
+ $this->warnings[] = 'extra.branch-alias.'.$sourceBranch.' : the target branch ('.$targetBranch.') must end in -dev';
unset($this->config['extra']['branch-alias'][$sourceBranch]);
continue;
@@ -203,7 +203,7 @@ public function load(array $config, $class = 'Composer\Package\CompletePackage')
// normalize without -dev and ensure it's a numeric branch that is parseable
$validatedTargetBranch = $this->versionParser->normalizeBranch(substr($targetBranch, 0, -4));
if ('-dev' !== substr($validatedTargetBranch, -4)) {
- $this->errors[] = 'extra.branch-alias.'.$sourceBranch.' : the target branch ('.$targetBranch.') must be a parseable number like 2.0-dev';
+ $this->warnings[] = 'extra.branch-alias.'.$sourceBranch.' : the target branch ('.$targetBranch.') must be a parseable number like 2.0-dev';
unset($this->config['extra']['branch-alias'][$sourceBranch]);
}
}

0 comments on commit ec7088a

Please sign in to comment.
Something went wrong with that request. Please try again.