Skip to content

Setup Zendframework 2 and twitter bootstrap using Composer #1613

Closed
aravind666 opened this Issue Feb 23, 2013 · 1 comment

2 participants

@aravind666

I am currently using composer dependency manager for zendframework 2 along with twitter bootstrap , I able to successfully manage zendframework 2 but I am not able manage twitter bootstrap via composer .

The problem is composer downloads twitter bootstrap library to vender directory . This is not feasible I need composer to download twitter bootstrap to public folder and zendframework to vender folder . how to achieve this

Below is the current composer.json file that I am using .

{
"name": "zendframework/skeleton-application",
"description": "Skeleton Application for ZF2",
"license": "BSD-3-Clause",
"keywords": [
"framework",
"zf2"
],
"homepage": "http://framework.zend.com/",
"require": {
"php": ">=5.3.3",
"zendframework/zendframework": "2.",
"twitter/bootstrap":"2.
"
},
"extra": {
"installer-paths": {
"public/bootstrap/": ["twitter/bootstrap", "twitter/bootstrap"],
"vender/zendframework" : ["zendframework/zendframework" ,"zendframework/zendframework
}
}

}

I am new to composer Please kindly suggest correct way of specifying path for each required library in composer.json file ,

The above code is throwing error as invalid format .

Is this way of specifying different path in composer is not permitted

Thanks in advance for responding . I created a Stack overflow posting also for this
I didnt get proper response from any one .

Please kindly suggest a work around

@Seldaek
Composer member
Seldaek commented Feb 23, 2013

Composer is not made to download frontend dependencies at the moment. Please check out Bower.

@Seldaek Seldaek closed this Feb 23, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.