Incorrect Version Installation #1724

Closed
c9s opened this Issue Mar 24, 2013 · 6 comments

Projects

None yet

2 participants

@c9s
c9s commented Mar 24, 2013

I defined the "require" like this:

{
"require": {
"corneltek/lazyrecord": "1.9.*"
}
}

I have corneltek/lazyrecord 1.9.7 in my satis repo, but the composer keeps installing 1.9.0.

Reinstallation or update seems don't work.

@c9s
c9s commented Mar 24, 2013

~ tild operator seems don't work too:

    "corneltek/lazyrecord": "~1.9"
@c9s
c9s commented Mar 24, 2013

OK, it's my fault, I just found that I required a non-existing package in 1.9.8. But I guess that would be better to have a warning when a version does not contains composer.json (?)

@c9s c9s closed this Mar 24, 2013
@igorw
Contributor
igorw commented Mar 24, 2013

I tried with your repo and could reproduce. So I tried to install 1.9.7 specifically and it told me:

Problem 1
  - Installation request for corneltek/lazyrecord 1.9.7 -> satisfiable by corneltek/lazyrecord 1.9.7.
  - corneltek/lazyrecord 1.9.7 requires corneltek/sqlbuilder dev-master -> no matching package found.

Which quite obviously means that it is a stability problem. You can either lower the minimum-stability or add a @dev stability flag for corneltek/sqlbuilder in the root package.

See also:

@c9s
c9s commented Mar 24, 2013

Thank for helping me verify this problem. :)

@c9s
c9s commented Mar 24, 2013

OK, I now have the composer.json for serializerkit and I've make sure that I push tags 1.3.* for sqlbuilder, but the satis seems don't update the tags for the sqlbuilder repo, which only shows dev-master and dev-devel.

So I guess that's why composer can't install the latest lazyrecord for me. Trying to find out why that satis does not update tags for me...

@c9s
c9s commented Mar 24, 2013

Sorry my fault again, in the tagged versions, there is no composer.json

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment