I defined the "require" like this:
I have corneltek/lazyrecord 1.9.7 in my satis repo, but the composer keeps installing 1.9.0.
Reinstallation or update seems don't work.
~ tild operator seems don't work too:
OK, it's my fault, I just found that I required a non-existing package in 1.9.8. But I guess that would be better to have a warning when a version does not contains composer.json (?)
I tried with your repo and could reproduce. So I tried to install 1.9.7 specifically and it told me:
- Installation request for corneltek/lazyrecord 1.9.7 -> satisfiable by corneltek/lazyrecord 1.9.7.
- corneltek/lazyrecord 1.9.7 requires corneltek/sqlbuilder dev-master -> no matching package found.
Which quite obviously means that it is a stability problem. You can either lower the minimum-stability or add a @dev stability flag for corneltek/sqlbuilder in the root package.
Thank for helping me verify this problem. :)
OK, I now have the composer.json for serializerkit and I've make sure that I push tags 1.3.* for sqlbuilder, but the satis seems don't update the tags for the sqlbuilder repo, which only shows dev-master and dev-devel.
So I guess that's why composer can't install the latest lazyrecord for me. Trying to find out why that satis does not update tags for me...
Sorry my fault again, in the tagged versions, there is no composer.json