Downgrading packages to more stable versions fails in non-obvious way if there is no matching package #2061

Seldaek opened this Issue Jul 3, 2013 · 3 comments


None yet

2 participants

Seldaek commented Jul 3, 2013
    - Installation request for doctrine/doctrine-fixtures-bundle ~2.1 -> satisfiable by doctrine/doctrine-fixtures-bundle[2.1.x-dev].
    - Removal request for doctrine/doctrine-fixtures-bundle == 2.1.9999999.9999999-dev

The error reporting should be adjusted probably if the only matching package is in the installed repo and does not pass a Pool::isAcceptable check

gggeek commented Nov 22, 2013

Does it relate in any way to this #1740 ?

I had a similar "cryptic" error message when running update, which was solved by keeping minimum-stability in main composer.json to dev and adding prefer-stable...

Seldaek commented Nov 22, 2013

I guess that can help fix it, because then you are not downgrading packages by removing the old ones, but rather just saying you prefer a more stable one.

@Seldaek Seldaek modified the milestone: 2.0, Bugs Apr 13, 2016
Seldaek commented Apr 13, 2016

Needs to be checked for 2.0 with the new pool changes.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment